New Nari Ultimate problems

Discussion in 'Razer Synapse 3 Beta' started by Nectros, Mar 25, 2019.

Thread Status:
Not open for further replies.
  1. Nectros

    Nectros New Member

    So, I just unboxed my new set of Nari Ultimate headset yesterday. I fired up YouTube to my fav genre of music and was pleasantly surprised, but shocked at the haptics...I figured it was just something new that I needed to tweak. And that's where my experience went downhill.


    After a full charge the haptics didn't work at all, no matter how much I adjusted the intensity. I clicked Bass boost too and nothing happened, now just a normal set of headphones... After doing some reading, I realized I might need an update to Windows 10, and I did. I work 3rd shift so I plugged the headset back in to charge while I went to bed while waiting for the operating system update.


    After the update to Windows, I turned on the headset and it was the same, no haptics, no matter what intensity was selected.... UNTIL I enabled Bass Boost, then the haptics fired up.... kind of weird, it’s like it needed something else to turn it on. haptics still worked (thank God) after I turned off Bass Boost. At the time I'm writing this the haptics is still working. Problem 1 solved.


    Now to test the Mic. Fired up Discord and head to the settings page. Currently its set to default, so I click the "Mic test" and I get nothing. So, I head into Windows and check and make sure it’s not my setup. I grab the install book and verify that Nari-Game is set up as set up as default game and that the Nari-chat are set up as default communication device. I click "configure" at the bottom of the Recording tab, to attempt to see if Windows can hear the Mic. Now I'm at the "Speech Recognition" window. I click” Set up microphone", and select "Headset Microphone", click next. Now I'm at "Adjust the volume of Headset Microphone(2-Razer Nari Ultimate-Chat)" and I get nothing... It goes to the next screen that asked me if my mic is muted, I look down and it’s not red....so No its not muted.


    Swapped USB to another port attempted everything above again to try get the mic to work with the same result.



    By the way, I am "upgrading" from a pair of $35 Logitech's in which my mic worked flawlessly.
     
  2. Grimmwor

    Grimmwor Active Member

    Nearly all of Razer's marketing is focused on new product releases and being a gaming company. Truly, they don't care about their customers. I recommend you consider your losses and move on to a company which is more reputable, reliable and valuable.
     
  3. Grimmwor

    Grimmwor Active Member

    My Razer headset also did not work on Discord. I am a top 5% Destiny 2 PVE player, and I got so tired of joining raids where everyone said I sounded like a robot. Even my $10 gas station headphones work better. It's def a software problem, because it works fine on other apps. I wonder if anyone at Razer ever thought of calling someone at Discord to discuss the rather prevalent and widespread software issue? Probably they just don't care.
     
  4. Nectros

    Nectros New Member

    Well, I tried the wire, and the mic works. Problem is that I paid $200 for something that my $35 Logitech's had no problem executing, albeit the Haptic feedback is nice, it doesn't warrant the high cost.

    I'm 48 hours away from returning these to Amazon and getting some Hyper X's.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >