New Razer Synapse as of today, cannot login

Discussion in 'Razer Synapse 3 Beta' started by GODzillaGSPB, May 13, 2019.

  1. GODzillaGSPB

    GODzillaGSPB Member

    ...and please don't ask about the version because I...cannot login!

    I've been greeted by this new fancy design and this is what I get when I try to login:

    [​IMG]

    I have to say, at this point I'm almost beyond fed-up with this. The Software gave me so much trouble over the past months but now it was finally working as intended and now this. I cannot...anymore!

    It's especially perfect because tomorrow Rage 2 releases, a shooter that demands a good mouse and a good keyboard. And I have that, both from Razer. And both are now not working because your driver needs a bloody login! Wow...
     
    Shannara likes this.
  2. GODzillaGSPB

    GODzillaGSPB Member

    PS: Was able to get the versions, it's Razer Central v7.3.16.115 and Razer Synapse 3.4.415.41818
     
  3. Ja50nKruy5

    Ja50nKruy5 New Member

    Same here. Login details are fine, as I have used them to log in to reply to this post!
     
  4. Shannara

    Shannara New Member

    Hello,
    same problem here since today. Version: 3.4.415.41818
    I really wish there was an offline profile storage..
     
  5. Shannara

    Shannara New Member

    Update: I managed to login after PC reboot.
     
  6. GODzillaGSPB

    GODzillaGSPB Member

    Fixed it by completely uninstalling, then using a cleaning tool (this step is probably optional, I use CCleaner), restarted, reinstalled, now I can login. I'm currently staring at a bar that represents the cloud synchronization though, it is not moving. Now it vanished. Keyboard and mouse are not recognized, even after physically reconnecting them. So, maybe I have to wait longer for the sync...

    Nothing is happening. Closed Razer Synapse, as usual had to end some processes via task manager, restarted it again, now the cloud sync bar and nothing is happening.

    I guess this all comes down to their cloud. Seems to be a problem there. Oh the joys of an alway-on-driver!!!
     
  7. Draid730

    Draid730 New Member

    I just had the same problem with Cortex and Razer Central. Repairing Cortex from Apps and Features worked for me
     
  8. GODzillaGSPB

    GODzillaGSPB Member

    So, everything works again. Like I said:

    • uninstall, clean with a cleaning software as an option, restart pc
    • download Razer Synapse 3 Beta installer, install
    • try to login, worked instantly for me after reinstall
    • give it some time for the cloud sync as it redownloads your profiles

    I hope it helps everyone else. It's really unfortunate that we have to stand this cloud based always-on driver, but here we are. -.-
     
  9. Rubyleetretro917

    Rubyleetretro917 New Member

    [QUOTE = "GODzillaGSPB, post: 489373, member: 856712"] ... e por favor não pergunte sobre a versão porque eu ... não consigo logar!

    Eu fui recebido por este novo design extravagante e é isso que eu recebo quando tento fazer o login:

    [​IMG]

    Eu tenho que dizer, neste momento estou quase além disso. O Software me causou muitos problemas nos últimos meses, mas agora estava funcionando como planejado e agora. Eu não posso mais!

    É especialmente perfeito porque amanhã Rage 2 lançamentos, um atirador que exige um bom mouse e um bom teclado. E eu tenho isso, ambos da Razer. E ambos agora não estão funcionando porque o seu motorista precisa de um login sangrento! Uau ... [/ QUOTE]
    entro assim
     
  10. GODzillaGSPB

    GODzillaGSPB Member

    If google translator is correct: Well, good for you, mate. ^^
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >