Nextbit Robin bootloader went back to locked after reboot; also no cellular signal.

Discussion in 'General Q&A' started by merb, Aug 22, 2017.

Thread Status:
Not open for further replies.
  1. merb_no_id

    merb_no_id New Member

    Hi,

    Title says it all; I bought my Nextbit Robin back in July, through third party store (live in Indonesia, bought from Amazon). BNIB, went straight to OTA android update (Nougat 7.1.1) after unboxing.

    After all updates are installed, everything looked fine, phone is working as intended, except no cellular signal. Cellular operator is recognized, but reads "Emergency Calls Only" on notification bar. When I tried to make a call a "Cellular network not available" popup appears.

    Tried multiple other SIM but the problem persist. All SIMs worked fine on other phone, so it's not the card. Tried other fixes but nothing worked (airplane mode on/off, reboot device). Using *#*#4636#*#* code (phone info), IMEI number reads fine, phone number reads fine, current network none, signal strength -51 dBm 31 asu (so there IS signal, no?)

    At this point I figured it might be a broken modem/radio files that needs to be re-flashed. Onto the rooting process I went. Enabled developer options, ticked OEM unlocking, ticked USB debugging. All ADB/fastboot required files already installed on PC, along with all necessary drivers (Google's and Nextbit's). Checked USB connection with 'adb devices' command, no problem.

    So I went ahead with the 'fastboot oem unlock' command, prompt reads OKAY, phone rebooted into android circle logo with 'erasing' on the bottom, rebooted again into homescreen, no problem.

    I then went back to bootloader to root, but here's the problem. All flashing command returns FAILED <remote: device is locked...>.
    fastboot oem device-info reads: Device tampered: false, Device unlocked: false. So bootloader is locked. At this point I assume that the bootloader is unlocked, but revert back to locked after reboot (the phone automatically rebooted after executing oem unlock command, so can't get around that).

    Tried numerous other methods, using different adb files, no dice. Can't even flash TWRP. Tried adb sideload, same. Tried executing fastboot oem unlock with various different parameter, still locked after reboot. I cannot flash anything into locked bootloader.

    Google researched it for few hours, same problem happened to other phones from other manufacturers that came returned from warranty replacement with modified motherboard; OR tampered/broken eMMC/NAND flash. But no such case for Nextbit Robin (yet?).

    Pretty hopeless right now since I just found out that Nextbit Robin support ended on Aug 1st.

    Guess I'm stuck with locked bootloader and no cell signal phone. Unless someone can help. One can always hope.

    Anyway, thanks for reading.
     
  2. sfbest23

    sfbest23 New Member

  3. merb_no_id

    merb_no_id New Member

    Did that already. Same :slightly_sad:

    Code:
    C:\N108>set ANDROID_PRODUCT_OUT=C:\N108
    
    C:\N108>fastboot devices
    ea25222 fastboot
    
    C:\N108>fastboot -i 0x2c3f -w flashall
    target reported max download size of 536870912 bytes
    wiping userdata...
    Creating filesystem with parameters:
        Size: 27258744832
        Block size: 4096
        Blocks per group: 32768
        Inodes per group: 8160
        Inode size: 256
        Journal blocks: 32768
        Label:
        Blocks: 6654967
        Block groups: 204
        Reserved block group size: 1024
    Created filesystem with 11/1664640 inodes and 148516/6654967 blocks
    wiping cache...
    Creating filesystem with parameters:
        Size: 268435456
        Block size: 4096
        Blocks per group: 32768
        Inodes per group: 8192
        Inode size: 256
        Journal blocks: 1024
        Label:
        Blocks: 65536
        Block groups: 2
        Reserved block group size: 15
    Created filesystem with 11/16384 inodes and 2089/65536 blocks
    --------------------------------------------
    Bootloader Version...:                                            
     
    Baseband Version.....:                                            
     
    Serial Number........: NBQGLMB6B1801240
    --------------------------------------------
    sending 'boot' (12413 KB)...
    OKAY [  0.421s]
    writing 'boot'...
    FAILED (remote: device is locked. Cannot flash images)
    finished. total time: 0.499s
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >