Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Nextbit Robin not recognized by Windows 10

Discussion in 'General Q&A' started by ThatOneGamer999, Aug 7, 2018.

Tags:
Thread Status:
Not open for further replies.
  1. ThatOneGamer999

    ThatOneGamer999 New Member

    Hey there,

    For the last week or so I've been trying to root my Robin and install a custom ROM, but Windows 10 stubbornly refuses to talk to it. I've tried every port imaginable, a USB 2 and 3 ports, along with USB 2 and 3 hubs. I've tried two different cables, and reinstalled the drivers multiple times. Every time I'm met with "Device descriptor request failed" from Windows. Also, I now cannot reinstall the Nextbit drivers, because I'm met with a popup that says "Scan for hardware changes fail. The operation completed successfully". Also when the drivers were installed, Windows refused to load them, saying the best ones were already installed. My devices settings should be correct, with USB debugging and OEM unlocking turned on, as well as USB mode set to MTP. Any help with this would be appreciated.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >