No sound from Speakers... Razer Blade Stealth 12.5 7500U

Discussion in 'Razer Support' started by trendDeerfront751, Sep 6, 2019.

Thread Status:
Not open for further replies.
  1. trendDeerfront751

    trendDeerfront751 New Member

    Hello, and thanks in advance for any help you can provide. :smile_:

    I'm having trouble getting sound from the speakers of my Razer Blade Stealth 12.5 (2016) Intel 7500U.
    And I've done some troubleshooting but can't seem to figure out if it's a driver or hardware issue.

    Here what I've done so far:
    - Of course the basics, such as confirming the speakers are not muted.
    - Checked if MIC is working, and it seems (per meter) to pick up sound, although I didn't actually record an audio
    - Checked if there's updated drivers on Razer's site, non available.
    - Checked if I get sound with Headphone, and I do get sound via headphones plugged to jack.
    - I reinstalled windows from the included recovery menu (which also includes the drivers from Razer) wiping my personal data, and STILL NO sound from speakers... (I backup my data prior to doing this)

    - I did a clean install of windows 10 1903, deleting all partitions, and the generic windows drivers WORKED!!! At this point, I was almost certain that it was a drivers issue. So I installed the audio driver from Razer's site to confirm, and immediately it reverted back to no sound in speakers.
    - I did a clean install a second time, and again speakers worked with Generic drivers. So I attempted to find an updated Realtek driver, with no success; and in the process again the sound stopped coming from the speakers.

    - At that point, I was ready to settle with the generic windows driver. So I yet again did a clean install, deleting all partitions, however I am NO longer getting sound even with the generic drivers... I've tried 2 more clean installs and still no sound.

    Now I am not sure if I have issues with my driver, hardware, or both.... And any assistance to resolving -or at least determining the root cause of this issue is appreciated.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >