No sound when using THX sound option after latest update

Discussion in 'Audio' started by girkers, Jan 21, 2022.

  1. coraxlord

    coraxlord New Member

    I am having the same issue with Kraken Tournament Edition and THX Spatial - Synapse not playing sound. I decided to download the trial for the standalone Razer THX SPATIAL AUDIO app to see if that worked. When I plug my Razer headset directly into the headphone jack (not the USB controller) I can get audio on the THX Spatial playback device. I've tried uninstalling all drivers, apps, and reinstalling but still can't get sound via THX Spatial - Synapse and I don't want to have to pay for the standalone app since it's supposed to be included with my headset.
     
  2. zebinat

    zebinat New Member

    I thought it was only me facing the issue but now I am very clear its update fault. I have updated my software twice and even changed my headsets but still the problem exists.
    Its pathetic they should better update it as soon as possible.
     
  3. same here with my Razer Kraken Tournament Edition, exat same problem as you zebinat
     
  4. patrickp376

    patrickp376 New Member

    I'm having the same issue. Headset still works perfectly fine using THX Spatial Audio app without synapse. I have to uninstall Synapse though because THX app won't let me load headphones stating "This is not required for Device as already has THX spatial audio. Please use Razer Synapses to configure its setting". However, audio isn't affected by any change of settings in Synapse. Uninstalling and Repairing Synapse is just a waste of time. Another option is to not use your headphones is not to use them through the USB audio Controller just plug them in you audio jack on sound card. then you can use the sound settings on the THX app. I have to go this route so I can use synapse for my mouse settings.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >