Nommo Pro not working...

Discussion in 'Razer Support' started by omarelsennary, Jun 27, 2020.

Thread Status:
Not open for further replies.
  1. omarelsennary

    omarelsennary New Member

    Good day, Razer,

    I'm having an issue with my Nommo Pro, It just won't power on...
    I have tried replugging all cords. I have tried different outlets. And nothing.
    Synapse is unable to detect the system since it is powered off, and the same goes for the Nommo Pro App.

    Worth mentioning, This particular issue happened to me before, and somehow out of pure luck, I have managed to get them working.

    I have not changed anything recently on my setup, Last time I used my Nommo was about 10 days ~ two weeks ago... because I'm usually running my Kraken Ultimate.

    This seems to be a common issue as i have seen multiple people with this exact issue here on the forums and on the internet in general.

    Awaiting your support with anticipation,
    Thanks
     
    TrueLekky likes this.
  2. omarelsennary

    omarelsennary New Member

    Looking forward to hearing back from you guys...
    UP ^
     
  3. omarelsennary

    omarelsennary New Member

    This is completely frustrating to have my thread seen by support members, yet be ignored without an answer -_-
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >