Nostromo stopped working after update

Discussion in 'Razer Support' started by Stormexia, Aug 19, 2019.

  1. Stormexia

    Stormexia New Member

    Hello everyone well I've had my Nostromo keypad for almost 5 years and last week when I updated my synapse my Nostromo seemed to be working fine but next day when I tried to used it I couldn't and I legit have tried everything... just recently tried to downloading an old Nostromo interface/synapse to see if the keypad could be recognized by the computer as a Nostromo and not a razer bootloader... which that's another thing my Nostromo is recognized by the computer as razer bootloader and not a Nostromo... anyone could help me with this issue?
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey @Stormexia. Thanks for directing your concern to our Support thread. By the way, does the issue happen while connecting the mouse to a different USB port or to a different PC with Razer Synapse installed?
     
  3. Stormexia

    Stormexia New Member

    Yep this issue still persists even after connecting my Nostromo to a different pc and different USB ports
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for confirming. Where did you see the Razer Nostromo acting as a bootloader? Please send me a PM together with your device serial number so I can check for its available updates. Let's continue from there.
     
  5. aeroLightBrown540

    aeroLightBrown540 New Member

    I am getting the same issue...Did an update and now my Nostromo is dead in the water. I've tried on multiple PC's as well. My PC reads the Nosstromo as "bootloader" in the device manager. I've tried downloading older drivers to no success.
     
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Have you tried connecting your Razer Nostromo to a different PC without a Razer Synapse installed?
     
  7. aeroLightBrown540

    aeroLightBrown540 New Member

    Yes I have, Both with it preloaded and then tried again with the software uninstalled. I was wrong where it said "bootloader" though.

    Under device manager on one PC it says "unknown device" But on my Main PC it shows up under "Universal Serial Bus controller" as "Razer Bootloader"

    It also shows up within "Bluetooth and other devices" under settings that it says "Razer Bootloader".
     
  8. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for letting me know. Please uninstall both bootloader and unknown device under your device manager and restart your PC. Should the issue persists, please send me a PM.
     
  9. aeroLightBrown540

    aeroLightBrown540 New Member

    PM sent, deleting and restarting did not fix the problem.
     
  10. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks! Let's continue from there.
     
  11. Razer.Speedcr0ss likes this.
  12. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >