nVidia Control Panel not installing after new SSD/RTX 2080 GPU Missing is Software

Discussion in 'Razer Support' started by Slaymetender, Jun 22, 2019.

Thread Status:
Not open for further replies.
  1. Slaymetender

    Slaymetender New Member

    I've got a weird one. I've got a brand new Razer Blade 15 with Oled, and 2 TB SSD, and 64 GB RAM. The first thing I did was replace the SSD and the RAM. Then I installed windows, all the drivers from Razer, and upgraded to windows pro. I started to notice issues in professional software, that the nVidia GPU isn't recoginized and it only uses the integrated Intel 630 graphics. One thing also, the nVidia Control Panel doesn't even install, no matter if I use the installer from Razer, or nVidia. Under Device Manager, it shows that the RTX 2080 driver is installed correctly and working. However, I'm not taking advantage of it, no matter what I do. Any idea how to get the computer to recognize the hardware, install the control panel and be used in After Effects, Touch Designer, Maya, etc. Is this a function of the OLED screen? I've done uninstalls of all nVidia and reinstalled using both drivers from the nVidia site and also the one from Razer. I haven't found the solution. Help would be appreciated greatly.

    Slaymetender
     
  2. Crysanna

    Crysanna New Member

    The Nvidia control panel is available now via the Windows Store. I had the same issue and get it.
     
  3. Slaymetender

    Slaymetender New Member

    I install that from winows and it tells me, "NVIDIA Driver is not installed on your system. To Use NVIDIA Control Panel, Install the latest NVIDIA Driver."

    As said, I've got the driver installed already, lost where to go.

    Slaymetender
     
  4. Slaymetender

    Slaymetender New Member

    btw, I brought this up with razer support in chat, and they went through one troubleshooting step, then recommending wiping the system and reinstalling windows. wtf?
     
  5. Crysanna

    Crysanna New Member

    I'm pretty much going to do a factory reset this morning as i've lost patience waiting for support to come back on my escalated issue.

    Can't use the Razer Blade with a Core X without having to reintstall the drivers every time. Case was escalated on Friday and i've heard nothing since
    No gaming mode on the Synapse 3 Performance Tab despute a full uninstall and reinstall of all the synapse
    Fans often running at full speed and have to quit synapse and turn it back on to slow them down
    Plethora of Windows errors
    Very frustrated especially after all the money we've spent.
     
  6. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello guys! I'd like to take a look at your cases. Can you send over the case number over to me through PM so I can check? I'll pick it up from there.
     
  7. Slaymetender

    Slaymetender New Member

    Sorry I’ve been in a weekend training course (using a different computer, since this) but I’ll get you that case number in the morning. I’m doing the reinstall thing now, btw.
     
  8. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the reply. I'll be waiting for your PM. Let me know how the reinstall goes as well.
     
  9. Slaymetender

    Slaymetender New Member

    The reinstall went fine although took forever and this is only windows, windows updates and the razer and Nvidia drivers. I can say that the Nvidia control panel Is installed and running now. So the solution of wiping the drive and starting over works but wow is it extreme. Now to optimize. Is there a way of disabling integrated graphics entirely?

    Slaymetender
     
  10. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Yes, clean installing Windows is definitely on the extreme end but there isn't much that we can offer if we don't know what previously transpired with your Support Tickets. Anyways, you can disable the iGPU via Device Manager under Display Adapters. Do note that this will affect the battery life of your laptop.

    P.S. Please continue with your convos with @Razer.RedPanda if you already have one.

    edit: replaced iGPU disable in BIOS to iGPU disable in Device Manager
     
    Last edited: Jun 26, 2019
  11. Slaymetender

    Slaymetender New Member

    Hmm are you sure that option exists on the blade bios? I don't think it does.

    On a related note, it does look like all my apps can be set to use Nvidia gpu using the Nvidia control panel, so I think I'm good!

    Slaymetender
     
  12. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    You're actually right. I might have been using an engineering sample for too long :stuck_out_tongue_winking_eye_:
     
  13. Slaymetender

    Slaymetender New Member

    Btw, I encourage this option to be put back in the bios. In class today, we showed out a Lenovo P1 could outperform the razer blade 15 with an rtx 2080 simply by disabling the integrated graphics.

    The teacher uses razer, and I use razer and we were both bummed that we didn't have that option in the bios.

    Slaymetender
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >