Overwatch and Diablo 3 crashing after installing Synapse 3

Discussion in 'Razer Synapse 3 Beta' started by Inetro1356, Feb 3, 2018.

Thread Status:
Not open for further replies.
  1. Inetro1356

    Inetro1356 New Member

    I recently bought a Razer Ornata Chroma which installed the Synapse 3 beta. However, it seems that Overwatch and Diablo 3 have stopped working on this computer in general. I have tried uninstalling all of the Razer software on my computer, rebooted multiple times, and even reinstalled Overwatch. But its still crashing.

    This all started after I installed Razer Synapse 3 and Razer Cortex. I am not sure what to try to fix it anymore, as I have deleted the files from Program Files and Program Files(x86) but these games just refuse to start like they used too.

    I tried live chatting with Razer Support but they could not find the issue, and I am starting to get concerned that a file is left behind somewhere and causing these things to fail.

    Any thoughts or advice on what to try?
     
  2. jackjack86

    jackjack86 New Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >