Overwatch Chroma - FIXED (June 28)

Discussion in 'Overwatch Talk' started by Razer|Quis, Jun 11, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. NO THEY DID NOT, stop posting if you don't have any confirmation, this is only confusing this post.
    As of today 19-06-2016 it has not been fixed. Either inform us how you fixed it or stop posting false information thx
     
  2. No it's not fixed.
     
  3. Zandar

    Zandar New Member

    I just installed 1.10.6 of SDK core and also i set the force interface in overwatch to on and it worked! Overwatch does still not show but it works for me i hope this helps
     
  4. Still not working for me, this is crazy it's been more than enough time to fix this issue, I personally bought my Razer equipment for this exact function, this is a big let down.
     
    Lesanka likes this.
  5. Zandar

    Zandar New Member

    check my reply

    well it didnt show up but!

    how I fixed it was i went into overwatch turned on force keybaord interface and i also got razer SDK 1.10.6 and opened it and installed it after that it was working. it still is ripple laggy but it still works razer synapse must be open! also OVERWATCH DID NOT SHOW IN APPS LIST BUT IT STILL WORKS
     
    Last edited by a moderator: Jun 19, 2017
  6. Gneekman

    Gneekman New Member

    So they didn't fix it, you found a workaround. There's a difference, you know.
     
  7. Zandar

    Zandar New Member

    Does it matter i still found a way to get it to work.

    How to fix!
     
    Last edited by a moderator: Jun 19, 2017
  8. Hucast

    Hucast Well-Known Member

    Ya, I have to agree with this, I just tried it and it didn't work. I don't want a work around, I want them to actually fix it.

    The path of least resistance you know?
     
  9. just wondering if synapse overwatch lighting integration problem has been solved yet? or are we still waiting? was the whole reason i paid hundreds for this keyboard (black widow chroma) thank you.
     
    Lesanka likes this.
  10. Hucast

    Hucast Well-Known Member

    Still waiting, but if you look at the threads on this topic I think someone came up with a workaround. Me personally, I don't want to do the work around so I'm just going to wait for them to fix it. Taking the path of least resistance you know?
     
  11. J0rmungandr

    J0rmungandr New Member

    Been a week and no updates or new info? This is looking bleak.
     
    Lesanka likes this.
  12. LucasBB

    LucasBB New Member

  13. ah, sorry didnt see this thread, i think the mods moved my question into here. Yes i also want a fix and not a work around that we have to do. lets do it right :)

    edit: Once razer delivers a fix patch, will synapse update automatically? or should we be clicking the "check for updates" periodically?
     
  14. LucasBB

    LucasBB New Member

    RookieTargaryen and Zandar like this.
  15. RyanChrist

    RyanChrist New Member

  16. BrianRevy

    BrianRevy Well-Known Member

    I too have thought I might have played with some settings by accident while I was half asleep but thankfully that wasnt the case xD
     
  17. LucasBB

    LucasBB New Member

    Only worked with 1.10.6 for me
     
  18. Zandar

    Zandar New Member


    This is a temporary FIX I reccommend getting the recent SDK when a fix comes out!
     
  19. Pen_Cap

    Pen_Cap New Member

    Workaround / Temp Fix
    (Until Razer Pushes An Official Update)

    Follow These Steps:

    Step 1: Close Razer Synapse. (Right click icon on Taskbar or use the Task Manager in Windows.)
    Step 2: Uninstall Chroma SDK Core Components version 2.2.4 (Control Panel -> Uninstall A Program)
    Step 3: Install Chroma SDK Core Components version 1.14.8. (Link Below)
    Step 4:
    Start Razer Synapse back up.
    Step 5: Start Overwatch.
    Step 6: Smile and yell as loudly as you can, "THANK YOU PEN_CAP! (Just Kidding! :blush:)"

    No restarts in between the uninstall and reinstall required but it never hurts!

    Working with the newest OW patch: Version (1.12.0.2.37456)

    I spent a few hours testing each of the Chroma SDK versions that have ever been released. I made sure to uninstall properly, delete temp files and do MANY (-.-) system restarts.

    All of the SDK versions can be found on Razer's Reddit Wiki Page found: **HERE**

    Here are my results: (Click Version Number For Direct Download)
    2.2.4 NOT WORKING (Newest Version/Auto Installed Via Synapse)
    [md5:7e207defe6d6856208be36a01f075df0]

    2.1.5 NOT WORKING
    [md5:1f010ccfe4ef2ded4a18d53727e83dd7]

    2.1.3 NOT WORKING
    [md5:1bf610626ca726c8f0e5ec46a95c1e2b]

    1.14.8 WORKING! (I would recommend using this version)
    [md5:5e29b0ec906ba53b3ab5887ac487b953]

    1.14.7 WORKING!
    [md5:c8e9ba77665dc8038077afc371b531c4]

    1.14.2 WORKING!
    [md5:693ce26844b4d4889f95f1f81cea0ed8]

    1.13.6 WORKING!
    [md5:57bdbd4fb317d22f637b5cbb37f09229]

    1.13.3 WORKING!
    [md5:4fd71b7e2965ca2c0e4d59b3d3d0ce26]

    1.10.06 WORKING! (Caused Random BSODs)
    [md5:46bea7c52baef22db474e5067dc78560]

    1.09.06 WORKING!
    [md5:0f626cdff1890471d5de2b528e04e791]

    1.07.05 WORKING!
    [md5:b529026eeec5d33540a0dff27c5c11d5]
     
    Last edited: Jun 25, 2017
    Legiolord17 and yobing like this.
  20. Spanjol

    Spanjol New Member

    This worked for me :) Issue is that my Orbweaver lights are not working with SDK 1.10.6 not only on Overwatch but in everything lol.. But will run with this until issue is fixed at least my Blackwidow, Mamba TE and Firefly are working :)
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >