Possibly Fix Synapse Doesn't Launch Problems

Discussion in 'Razer Support' started by GodlyYong, Aug 27, 2021.

Tags:
Thread Status:
Not open for further replies.
  1. GodlyYong

    GodlyYong New Member

    Hey, i've made a major breakthrough since i posted an issue. Here is the way i fix it

    1. run PowerShell as admin
    2. run command "netsh winsock reset" #requires a reboot, but we will do it later
    3. run command "dism.exe /Online /Disable-Feature:Microsoft-Hyper-V" #this shall disable Hyper-V function on your pc. If it's already disabled, ignore this step
    4. disable core isolation->memory integrity in Windows Defender. #and again, if is already disabled, ignore this step
    5. reboot your pc
    6. back to PowerShell (as admin)
    7. run command "netsh int ipv4 set dynamicport tcp start=49152 num=16384" #these numbers have been default data since Windows Vista, not recommended to change them(unless you completely understand what they stand for)
    8. run command "dism.exe /Online /Enable-Feature:Microsoft-Hyper-V" #this shall Enable Hyper-V function on your pc. Recommend to only enable it if it was disabled in step 3, i will explain the reason below.
    9. Enable core isolation->memory integrity in Windows Defender. #again and again, You should only enable it if it was disabled in step 4.(but i personally recommend you to turn it on, because it will make your pc safer, even helps defending Ransomware. Meanwhile, it will enable Hyper-V feature automatically, if it shall cause further problems, turn both Hyper-V and core isolation off by following step 3&4)
    10. take another reboot
    11. enjoy your razer equips
    WHY THESE COMMANDS?
    core isolation->memory integrity is a new secure feature that is based on Virtualization technology in Windows 10. Without a doubt, it does improve your pc security level. However, it would likely cause many problems. This feature relies on Hyper-V function, which is the root of many issues (the most common one is conflicting with Android simulators like bluestacks or other virtual machine software like VMware). In this case, Hyper-V changed my default dynamic TCP ports from 49152-65535 to 1024-13977, which is an outdated setting on Windows XP and before. Whenever a program tries to bind on a dynamic port in that range, system will raise a Permission Error, which causes unexcepted failures to the program (stopped my Synapse from launching in my case). So you can simply disable Hyper-V or change the ports manually to avoid such problem.

    HOW DID I FIND THE PROB?
    Well, i was trying to download something with aria2c, and it suddenly prompted error message "Failed to bind port 64xx. [...] An attempt was made to access a socket in a way forbidden by its access permissions.". My first thought was the port was taken by another program. So i ran command "netstat -ano | findstr "64xx"", but i got nothing returned. So i immediately understood it was caused by wrong net settings like dynamic ports. Then i ran command "netsh int ipv4 show dynamicport tcp" to check it, the result matched my guess.

    In the end, i don't take English as my first language, so do reach out me should you have any other concerns. And never hesitate to point out my language mistakes, it would actually be a great help. If anyone can translate my passage to more readable version, i'd be very glad. Feel free to reproduce my article.
     
  2. GodlyYong

    GodlyYong New Member

    Oops, i use # as Annotation sign like i did in python, but razer takes it the other wayo_O
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >