Pro Click Mouse Deadlocks - Two Died Within a Day

Discussion in 'Razer Support' started by MakaniKai, Jul 19, 2021.

Thread Status:
Not open for further replies.
  1. MakaniKai

    MakaniKai New Member

    I think there are some serious problems with the Pro Click mouse that need to be addressed. I purchased a Pro Click from Amazon (https://smile.amazon.com/gp/product/B08BQXL6DD/) and initially it worked fine. Then, within a day of use, it completely died. I know the battery was charged because I had it plugged in for more than 4 hours.

    When I say that it died, I mean that it became completely non-functional. No lights, no connectivity, no response from switching to 2.4GHz or Bluetooth or USB or "Off" or anything. No sounds when plugging into any USB ports. Nothing in the Bluetooth discovery menu. Absolutely dead. I tried leaving it on the charger for a while, but it never came back to life. There were never even any lights showing that it was being charged. I know that this mouse was on the latest firmware, because it was the first thing I checked when I got the mouse.

    I decided I must have received a dud, and I got a replacement from Amazon. New mouse arrived, and it was working fine. I used it for a day and plugged it in overnight. Came back the next morning and it worked until I unplugged it from USB, and then it completely died again, just like the first. No lights, no life at all. Even plugging it back into the USB port which was working 3 minutes ago did nothing at all.

    I have found many other people running into this problem across these forums, mostly going ignored:

    - Razer Insider | Forum - Mouse Razer Pro Click not working
    - Razer Insider | Forum - Razer Pro Click Won’t turn on
    - Razer Insider | Forum - Razer Pro Click
    - Razer Insider | Forum - Razer Pro Click won't turn on
    - Razer Insider | Forum - My Razer Pro Click suddenly won't work
    - Razer Insider | Forum - New Razer Pro Click keeps freezing for days at a time?

    I found a couple videos online of this exact problem, too:

    - RAZER Pro Click Stopped Functioning - YouTube
    - DSC_0363.MOV - Google Drive

    I have a masters degree in Computer Science, and I have extensive experience working with embedded hardware. I have noticed from the way this mouse behaves that it does not have any physical disconnect between the power source and the microprocessor. Because of this, there is no apparent way to invoke a RESET of the microprocessor that drives this mouse. I find it very likely that a firmware bug is sending the microprocessor into a deadlock state that is causing the mouse to turn into a paperweight.

    The only way I can see possible to trigger a RESET would be to let the battery eventually die. I can further confirm this theory because this poster mentions: "the only way i've found to fix it so far is to just let the battery run dry so it can 'restart' in a sense, but this often takes days at a time."

    I love the way this mouse looks and I hate to return it again, but I am already in the process of returning it to Amazon. I will purchase the mouse again if a firmware update addressing this bug is released, or another cause is identified. Right now, though, I am confident that there are serious firmware issues with this mouse that Razer engineers need to address.

    Thanks for any help.
     
    Last edited: Jul 19, 2021
  2. I had issues with my mouse as well, and I lost warranty time waiting for an upgrade; after finding no help from support or a logic solution, I just got another mouse, not Razer, of course. We are talking about a mouse; it has nothing special. I feel sorry for the customers that buy Razer laptops or something more complex and have issues!!
     
    MakaniKai likes this.
  3. MakaniKai

    MakaniKai New Member

    I've decided to try a third Pro Click mouse. First thing I did was make sure it was fully updated. I will post if I have any more issues. Hope all goes well.
     
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Have you contacted our Support Team? Ensure that the mouse is on the firmware v1.02.00_r1. Nonetheless, allow me to forward this to our Support Team/devs. Please send me a PM together with your device's serial number including your Razer Synapse 3.0 logs. Let's continue our conversation there. I'll be locking this thread now.
     
    Spaceman95990 likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >