Problem with Blackwidow chroma keyboard

Discussion in 'Keyboards' started by Macuvass, Jun 11, 2016.

Thread Status:
Not open for further replies.
  1. Niggaflip

    Niggaflip New Member

    So i've had my blackwidow chroma keyboard for a while but recently its been bugging out. So when i put it on spectrum cycling one key (key n) isnt showing the right colors (it's not just the spectrum cycling). When i updated the drivers its started working for a day but now it's still bugging. Is this my computer problem or is my keyboard just broken.
    Any help would be appreciated.
     
  2. ShamX0

    ShamX0 Active Member

    Well if its just individual key then you should test it with static colors. Then from there maybe a faulty led for that key. Coz i don't think synapse or software can cause the key to be of different color.
     
  3. Predator5

    Predator5 Well-Known Member

    Obsidian likes this.
  4. JeremyLWK

    JeremyLWK Active Member

    Yup, sounds like a faulty keyboard.
     
  5. Psyjin

    Psyjin Well-Known Member

    Like Exzero suggested, try setting your keyboard to different static colors. If you find that the 'N' key is a different color than the rest of the board, you have the same problem as many other Chroma keyboard owners. In this case the problem is with the keyboard itself, not your computer. Here are some example photos for reference so you know what to look for:

    [​IMG]
    [​IMG]
    [​IMG]
     
  6. I've been having a similar problem, but mine is stuck on wave, and none of the custom keys I have set work. I'm kind of disappointed at the quality of their software and hardware. If I can't solve this issue, I may switch to logitech or corsair.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >