Problem with Deathadder Chroma in Device Manager

Discussion in 'Razer Support' started by Admiral-Hunter, Mar 13, 2018.

  1. I have a Deathadder Chroma mouse which is not recognized by the device manager with its original name, so the Razer Synapse does not even know it is connected, i do not know what else to do in this regard, because the Synapse loads the drivers of the other peripherals however the mouse does not load it
     
  2. michalj82

    michalj82 Member

    Open Device Manager, then open mouse, keyboard and HID interface devices sections even if you only got problem with mouse and then right click on every position you got there and select update driver and select option that will make you select folder on hard drive and select this path: C:\Program Files (x86)\Razer\Razer_Common_Driver
     
    nagetife and Admiral-Hunter like this.
  3. thx, i guess that within that route should be the deathadder drivers downloaded from synapse or not?
     
  4. michalj82

    michalj82 Member

    I have same problem with mouse not recognized by Synapse and after I've reinstalled Synapse few times and reconnecting mouse I did what I've wrote above and it worked. :)
     
    Admiral-Hunter likes this.
  5. i'll have to try this last thing you tell me, the previous thing i did several times and it always tells me that the best drivers for that device are already installed, however i get Blackwidow Chroma mouse and the HID input and i do not understand why, i also get Blackwidow on the keyboard but this one is recognized by the Synapse without problems, my problem is with the mouse that i can not find the way that the Synapse recognizes it, i will try this last thing that you tell me to uninstall and install Synapse by disconnecting the mouse, once more grateful for your answer
     
  6. michalj82

    michalj82 Member

    You don't need to reinstall Synapse, just update drivers in device manager like i've wrote in my first post.
     
  7. Yasuozero9

    Yasuozero9 New Member

    guy can u help me
     
  8. what ur problem?
     
  9. Yasuozero9

    Yasuozero9 New Member

    i plugged my razer in and synapse said i wasn't plugged but when i see the device manager ,it was connected alredy
     
  10. it happens to me almost the same, sometimes neither the synapse recognizes it to me, i do not know if it will be the problem of the Windows version, i am using the 1709 Fall Creator and the Synapse 2 because the 3 is beta and still does not have the Chroma DeathAdder, i do not know what else to do, i've done everything, even looking for drivers in internet pages and nothing, still recognizes the HID and when i uninstall it to put another DeathAdder tells me that the best drivers for that device are already installed and returns install the automatic HID
     
  11. michalj82

    michalj82 Member

    But when you try to update drivers in device manager do you select this path ? C:\Program Files (x86)\Razer\Razer_Common_Driver
     
  12. yes, and then says: the best drivers for this device are already installed, i just have to go to the Microsoft forum to see if the technical support from there helps me
     
  13. michalj82

    michalj82 Member

    But you need to do this with every one in Mouse, Keyboard and HID interface devices not just the only one.
     
  14. my keyboard is Blackwidow TE Chroma V2 and headset Kraken 7.1 Chroma V2...i have no problems with them, they are recognized by the device manager and Synapse, it's just the mouse, the one that follows in HID without recognizing me Chroma DeathAdder, i use the Synapse 2.0 and Windows 10 1709 Fall Creator, I'll think about formatting to see if i recognized from the beginning the peripheral, to connect in synapse also does not detect the DeathAdder, that's what bothers me the most, i download all drivers less than that, it's more of OS, so i think I'll go to Microsoft looking for help with the devices...
     
  15. michalj82

    michalj82 Member

    I only have DeathAdder but it shows in mouse, keyboard and hid interface devices sections in device manager.
     
  16. can you upload the DeathAdder Chroma installer driver that is in the razer common_driver folder somewhere? if it's not a problem ... because what i do not download is that driver as such and that's why Synapse does not recognize me, maybe with this resolve
     
  17. michalj82

    michalj82 Member

    I would if I'd know which one is right, because there are lots of files there but they don't have mice names.
     
  18. Razer.FirePenguin

    Razer.FirePenguin Keeper of the Flames, Bane of Sardines Staff Member

    Hey! Try uninstalling the mouse driver and unplugging it. Then, restart your pc and wait for windows to fully boot up before plugging the mouse back in. There should be a pop up that there is a new device being installed.

    *Moving to the Support section
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >