Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Problems with Synapse 2.0 on Mac

Discussion in 'Razer Support' started by mvoldan, Nov 27, 2020.

Thread Status:
Not open for further replies.
  1. mvoldan

    mvoldan New Member

    Hi,
    I've got some issues with my mouse and the Synapse 2.0 on my MacBook.

    First of all, part of Synapse called "RzUpdater" is somehow making my mac unhappy. It starts out of nowhere and when that happens mac starts running it's fans like crazy. I suppose it's looking for new software updates, but why the hell does it needs so much power to run? Does someone else have the same problem? Is there a way to stop the RzUpdater or get rid of it completely?

    Secondely, today I updated my MacOSX Mojave to Big Sur. Ever since that, Synapse does not want to detect my mouse (Razer Atheris RZ01-02170100-R3G1) anymore. The mouse still works, it is connected to my laptop, but it just doesn't show up on synapse.
    Screenshot 2020-11-28 at 0.04.06.png Screenshot 2020-11-28 at 0.04.55.png Screenshot 2020-11-28 at 0.07.34.png
    I tried reinstall, restart... nothing helped. I triend looking for drivers for this mouse, didn't find anything, but what I found was "Razer Atheris Support" page where they talked about updating firmware on the mouse. It goes like this:

    Why is my Razer Atheris unable to reconnect back to my Mac?
    Please follow the steps outlined below to update the firmware of your Razer Atheris:
    Warning: Updating the Razer Atheris while in Bluetooth mode will cause an error.

    1. Ensure that the Razer Atheris is switched to 2.4GHz and is connected via the dongle.
    2. Use this link http://rzr.to/wiZMl and follow the steps of the updater

    This point is more about what Razer did wrong on their page rather then what they did with their sofware or hardware. If you click the link, it downloads the updater, which funnily enough is .exe! Not .dmg for mac, but .exe, so it's completely useless information and time spent if you don't have Windows near you (I don't). Either they are making fun of MacOS users or they're straight up stupid. Like if I have a problem regarding Mac then I obviously cannot solve that problem on Win now can I?
    Screenshot 2020-11-28 at 0.05.57.png
    Anyway, I don't know how to solve my problem regarding my mouse and synapse and so I'm asking for help. Why the synapse does not want to detect my mouse? Is it something the Big Sur update created or is it just synapse playing up? Is there a way to fix it?

    Thanks for any answers.

    RAZER! Please, make the Synapse 3.0 for mac, thx
     
  2. mvoldan

    mvoldan New Member

    UPDATE:
    I borrowed a laptop from my mate with Win 10 and updated the firmware... It still doesn't work on my mac, so that's that.
     
  3. mvoldan

    mvoldan New Member

    UPDATE:
    Reinstalled synpase 2.0 again and left it in 1.87.1 version. It shows this - Screenshot 2020-11-28 at 0.40.03.png Screenshot 2020-11-28 at 0.43.22.png . Meaning the software recognizes the mouse but also it doesn't. Confused as hell over here...
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Synapse 2.0 for mac only supports versions 10.14 and earlier. As far as I know, there won't be any support for later versions, and this has been discussed in multiple threads already. By the way, does your mouse work properly when used on a Windows PC? Please send me a PM so I can help you further isolate the issue. *Thread locked.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >