PSA: Macbook Pro USB ports and Razer products...

Discussion in 'Systems' started by creon254, Jul 10, 2019.

  1. creon254

    creon254 New Member

    Just got off chat with Razer support. I have a Macbook pro (purchased 2018) to use while traveling for a long while, and just picked up a Naga Trinity yesterday to use when WoW Classic comes out. FWIW i understand Mac's arent great for gaming, but i chose this mouse instead of the Corsair Scimitar or Logitech G600 because they do not work with Mac. I specially was looking for a MMO mouse.

    Was nervous when i opened up the box and plugged it in, as the 1-12 buttons werent working and wasn't showing up in razer synapse i.e. "Please connect a Razer synapse-enabled device"...uh oh wtf?

    So, after some time, i updated my MacOS software to the latest (Mojave 10.14.5), and the mouse is working great with the 1-12 buttons. MAKE SURE macOS IS UPDATED FULLY, should be a given but we learn.

    Though, I am still am getting the "please connect a Razer synapse enabled device" message in Synapse (mind you Synapse 3 isn't available for Mac users atm, we have to use 1.86), even though I can see on the top right of my screen/menu bar (little synapse icon where wifi icon is and such) that synapse is somehow detecting that it's a Razer Naga Trinity, even though I cannot see it in the menu/client whilst getting that same error message. Bleh.

    Support chat says it's because the mouse isn't "getting enough power", and due to Macbook Pro's having only USB-C ports, Razer Mac users are SOL on this for a long while. I have a USB adapter to use the mouse with as the mouse is USB 2.0, but apparently i cannot use the mouse and Synapse to its full potential because it's not "directly plugged into the Macbook".

    Kind of sucks, but at least the mouse is working in terms of the 1-12 buttons, and i can change DPI using the up/down keys under the scroll wheel. Just can't customize anything, change DPI settings, key bindings, colors, etc. :slightly_sad:
     
  2. creon254

    creon254 New Member

    EDIT: OKAY IDK WHY BUT IT'S WORKING. ALL I DID WAS RESTART MY MACBOOK, SYNAPSE WAS STILL SAYING IT BUT I SWITCH MY ADAPTER PORTS, CAN CONFIRM IT WORKS...FOR NOW
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >