QHD Razer Blade Stealth Freezing

Discussion in 'Systems' started by Rcarbajal, Mar 2, 2016.

Thread Status:
Not open for further replies.
  1. rcarbajal

    rcarbajal New Member

    Hello everyone. Just got my stealth yesterday, Monday. Initially had no problems and was simply impressed by this amazing laptop, however, I've had 2 random instances in which it freezes on me completely and the only remedy was to forcibly shut it down both times. The first time it froze, it was simply on the desktop screen, idle, and charging. The Second time was while just browsing the web. Any suggestions or thoughts?

    Update: Froze a third time with HW Monitor running in the background with avge temps of 37 Celsius
    Update 2: Decided o just go with an RMA
    Update 3: Received my replacement within about a week of doing the RMA and so far so good. No freezing within the 2 days I've had it. Something also to note is that this replacement, gives me a battery life estimate, whereas the first stealth would just say 'calculating' all the time.
     
    Last edited: Mar 18, 2016
    Circuit.Board likes this.
  2. NazgulStig

    NazgulStig Well-Known Member

    Does it happen when you leave it idle right after boot?
     
  3. rcarbajal

    rcarbajal New Member

    No I would say I had about 2-3 hours of using it already before it froze on me both times that it did.
     
  4. NazgulStig

    NazgulStig Well-Known Member

    Can you install HWmonitor and monitor the temperature during use?
     
  5. Is it freezing on you when you are actively using it, or has it been idle for a while? Mine has frozen on me twice before, but those were due to inactivity and related to sleep mode. Your first example sounds similar so could it be something to do w/ Windows 10 sleep mode or power settings?
     
  6. jiauuwou

    jiauuwou Member

    Open Event Viewer and check Custom Views > Administrative Events .
    Maybe you can find out the reason of the freezes ...
     
  7. rcarbajal

    rcarbajal New Member

    Just had it on for about an hour of very light use and some idle mins and froze again with a temp average of 37 celsius

    first time was complete inactivity and had it plugged in to the ac. Second I had just watched a youtube video on my chromecast with it, then right after disconnecting from the chromecast, it froze. I had Sleep disabled when plugged in, the first time it froze. Second and third time, to sleep after 45mins plugged in.

    [​IMG]
     
    Last edited by a moderator: Aug 13, 2016
  8. NazgulStig

    NazgulStig Well-Known Member

    Interesting, so its not thermal issue. Contact Razer Support a technician will be able to help you with the issue. Check my sig for the link to Support.
    Just saw this now.. are the time shown here the same as the time your system freezes?
     
    Rcarbajal likes this.
  9. rcarbajal

    rcarbajal New Member

    emailed them last night. Still waiting for an answer maybe i'll just call in a bit thanks

    yes this is a screenshot after force restarting from my 3rd freeze a few mins ago
     
    Last edited by a moderator: Aug 13, 2016
    NazgulStig likes this.
  10. NazgulStig

    NazgulStig Well-Known Member

    The culprit seems to be Event ID 7023
    It deals with services and driver services. Lets wait for the support to sort this out.
     
  11. Yousif47

    Yousif47 Active Member

    HI there
    if the both instances the system was plugged in then there is an update for that
    it is EC update and should fix windows slowing down during chargind
    you can find it in the support page of razer blade stealth
    if that did't help I suggest factory reset
     
  12. rcarbajal

    rcarbajal New Member

    did the update after the first 2 freezes. I'll see what support tells me at this point.

    so I just got off the phone with support and I will be getting a replacement unit. Hopefully it isn't another lemon. Thanks guys for helping out.
     
    Last edited by a moderator: Aug 13, 2016
    NazgulStig likes this.
  13. NazgulStig

    NazgulStig Well-Known Member

    Nice :) :thumbsup:
     
  14. VI510N

    VI510N New Member

    Also have had the same freezing/lockup occur three times. Twice on a UHD RBS and once more on my new QHD RBS. My instances have been while I'm only on battery and not plugged in. While I truly to really enjoy this laptop, its speed and design, I don't know if I can tolerate something like this to further happen, especially if I'm working on any documents that haven't been saved etc.
     
  15. rcarbajal

    rcarbajal New Member

    ouch really hope we just got bad units cause I really want to daily this one for work

    just an update on my situation here, Razer support has just hooked me up with a 2nd day label to return this defective stealth and was told that I would also get priority shipping for my replacement. So as far as customer support goes, I cannot complain yet :big_grin_:
     
    Last edited by a moderator: Aug 13, 2016
    Xevien and NazgulStig like this.
  16. arcluna

    arcluna New Member

    Sadly I am having the same issue. I have the 512 UHD, and already have sent my old Stealth back to Razer, and just received my replacement yesterday.

    Unfortunately the issue is happening again.
    I was watching a youtube video when it froze, and yesterday I was just on facebook when it froze.

    I've also put in Starcraft (the original old game-so not exactly intense gaming) and have experienced a number of momentary pauses and then the game will continue.

    Here's a very ironic video of the stealth frozen when I was watching a youtube review on the Razer Mamba...
    https://www.dropbox.com/s/sr134yaxtwh9hom/IMG_6388.MOV?dl=0

    I'm not really happy about this...
     
    Last edited: Mar 3, 2016
    VI510N likes this.
  17. rcarbajal

    rcarbajal New Member

    sorry to hear :slightly_sad: third times the charm?
     
  18. arcluna

    arcluna New Member

    [​IMG]

    Here's hoping to the 3rd one...
     
    Rcarbajal likes this.
  19. worthymatt

    worthymatt Member

    I am having this issue now, along with cursor jump and a blue screen today, and this is my 2nd stealth (exchanged a UHD for QHD). At this point I really feel like the first generation Stealth has too many issues and I'm considering returning this one and getting a Blade FHD on current sale instead which will likely last me the next two years just fine, and then get the 2nd or 3rd Gen stealth when all the kinks have been worked out.
     
  20. rcarbajal

    rcarbajal New Member

    just got my replacement stealth today and so far so good. The test of time begins.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >