Razer 17 Pro 2020 RAM Upgrade Options

Discussion in 'Systems' started by sergeantash, Oct 28, 2020.

Thread Status:
Not open for further replies.
  1. sergeantash

    sergeantash New Member

    I've given up waiting for Support to respond with which RAM upgrades actually work with this bl**dy laptop, so I'm hoping that the community can help.

    I have ALREADY tried Crucial Ballistix (1.35v) and found that it wasn't XMP compliant, infact the machine wouldn't even boot with XMP enabled in Bios. I've also tried HyperX 3200 (1.2v) and while it was XMP compliant, the machine consistently crashed when pushed.

    So now the options are as follows:
    Has anyone tried the two above, if so have you really pushed the machine (Razer 17 Pro 2020) with gaming such as Battlefield 5 etc?

    Really desperate for this RAM upgrade now and don't want to have to send any more chips back having wasted time testing them!!
     
    pancholr likes this.
  2. dudepare01

    dudepare01 Active Member

    I am still waiting for my HyperX 32 GB set (CL17, 2933 Mhz Jadec).

    I hope this would be a quick swap as 1, it has the same rated max memory speed for the 10th gen I7 and 2, it does not require an XMP profile to run that speed.

    Will update you once I get my set (Hopefully next week)
     
  3. rjkrejci

    rjkrejci New Member

    I bought the 32GB 3200 HyperX (1.2v) for my Razer 17 Pro 2020 and I've not had a single crash despite hours of play with MSFS 2020 which is an extremely demanding game memory-wise. Bios 1.04. Runs at 3200 even not selecting XMP profile in the bios (confirmed using HWiNFO64).

    I had the same crashes you did with the Ballistix 1.35V
     
  4. pongwon

    pongwon New Member

    I had less success with the HyperX 2933mhz memory and had more system crashes than the HyperX 3200mhz. The 3200 still crashed for me though. Running bios 1.04 and using the 2933mhz xmp profile was better but games still crashed.
     
    Last edited: Oct 28, 2020
  5. sergeantash

    sergeantash New Member

    Thanks for the replies guys, @rjkrejci it's interesting that you're not seeing any crashing, Battlefield 5 is far more demanding that Flight Simulator in my experience due to the massive difference in on-screen action and raytracing features. I won't be trying the 3200 again, I'm tempted now to try the Vengeance next!
     
  6. rjkrejci

    rjkrejci New Member

    I don't know the amount of stress the action and Raytracing puts on the System memory vs. the GPU and it's memory. MSFS 2020 has just a massive amount of textures and long distances. It's using 16-17 GB of RAM memory constantly while playing and I've had it running for many hours. Did you select the XMP profile or leave it at default? I left it at default, and it still runs at 3200.
     
  7. sergeantash

    sergeantash New Member

    Yes I tried the default XMP profile which is selected automatically at 3200mhz, I also tried the lower 2933mhz profile but no success, still crashes after about 15 minutes of gaming :slightly_sad:
     
    Last edited: Oct 29, 2020
  8. COSMICFILMS

    COSMICFILMS New Member

    Man I'm sick and tired of not getting any straight answers to this.... I'm in the same boat and Razer refuses to provide any answers.... I paid 5K for a laptop and there's no information about a simple thing like upgrading the ram??? Looking for 64GB.
     
    storyBlushhead959 likes this.
  9. sergeantash

    sergeantash New Member

    It's shocking isn't it, sadly this will be the first and last Razer that I'll buy, next time it's an Alienware for me!
     
    storyBlushhead959 likes this.
  10. dudepare01

    dudepare01 Active Member

    Received and installed Kingston HyperX 32Gb (CL16-2933 Mhz) worked like a charm. I did have some black screen at the beginning and only the keyboard was lighting. It turned on and off (while screen is black) for a few times before it finally came to life. Stress test and game test passed.
     
  11. sergeantash

    sergeantash New Member

    Thanks mate, the worry is that I've tried the 3200 and it was fine at first until I pushed it via gaming, have you really pushed this ram since installing it?

    I've ordered the same ram tonight, I'll push it the same way as the 3200 and see how stable it is, I'll report back!

    If it fails, I'll send it back and try the Corsair 2666mhz instead...and if that fails then I'll sell the laptop because the only conclusion can be that it's sh*t...
     
    Last edited: Nov 1, 2020
    SOMNIOHM likes this.
  12. dudepare01

    dudepare01 Active Member

    I have the 2Rx8 and correction, it is a CL17@2933Mhz btw...tested in with Forza Horizon 4, Star Wars Fallen Order, Prime95 blended (maxes the ram), Cinebench R20 and Geekbench 5 benchmarks...passed! I did have some black screens at the beginning which quite scared me but it worked after a while and went on to start windows. XMP profile 1 is same as the default and XMP 2 is 2666Mhz CL16
     
  13. dudepare01

    dudepare01 Active Member

    Hope this helps

    HWinfo.JPG
     
  14. sergeantash

    sergeantash New Member

    Thanks mate, I have the same machine but with 2080 Super Max Q, good that you've pushed it so fingers crossed this ram will work for me too!
     
  15. rjkrejci

    rjkrejci New Member

    Yea, putting in new memory takes a few iterations of POST before it makes it to windows. Agreed, the first time it does it it's a little stressful.
     
  16. sergeantash

    sergeantash New Member

    Yeah agreed I remember that with the 3200 HyperX, the Crucial RAM however just hung on black screen!!

    Will report back once new ram arrives!
     
  17. rjkrejci

    rjkrejci New Member

    Yea, I had to pull the CMOS battery to bring it back to life with the Ballistix, even if I put the memory it came with back in.
     
  18. sergeantash

    sergeantash New Member

    Yeah same here, took a long time to get it working again, disastrous!
     
  19. storyBlushhead959

    storyBlushhead959 New Member

  20. seanjmary

    seanjmary New Member

    Installed Kingston Hyper X 64 GP 3200 MHz ram into my Pro 17 2020 machine. On Bios 1.04, it would run ok, then hang up after a little bit. This behavior was unexpected as it ran fine on 32 Mhz. Behavior happened usually when using Adobe programs. After reverting back to 32GB Hyper X (2 16GB Sticks) issue again disappeared. Returned ram as I didn't feel like dealing with it at that point. Was too dependent on the machine operating stably to continue to mess around with it until I heard a definitive resolution.
     
    SOMNIOHM likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >