Razer Atheris - stops responding

Discussion in 'Razer Support' started by Vamarelon, May 7, 2018.

Thread Status:
Not open for further replies.
  1. Vamarelon

    Vamarelon New Member

    Hi Guys, hopefully someone can suggest a fix for me.
    I've been having issues with a Razer Atheris switching off or at least stopping responding.
    On the original system is was installed on this could be mid game so you can see how that would be annoying.
    That was set up with the 2.4 dongle on a Windows 10 system. I tinkered with power saver settings, Synapse updates and clean install, no change.

    To see if I needed to raise a warranty issue I've brought it into the office and set it up on my work laptop.
    Clean install of Synapse and as I have access to Bluetooth on this system set it up that way, to eliminate USB and USB related issues. I put in a fresh set of Duracells as well just in case it was something that silly.

    I'm not playing any games just using it all day as a regular mouse and I still have problems.
    Restarting Synapse doesn't bring it back but changing the selector switch on the bottom does.
    I set sleep mode on the mouse to 10 minutes but its stopped responding on me a couple of times.

    I tried to raise a support ticket but this mouse isn't an option.

    Any suggestions?
    DRIFT_IT and pancholr like this.
  2. Vamarelon

    Vamarelon New Member

    Emailing support on a general category got a ticket raised for this issue.
    I've followed the steps supplied and so far so good.
    Essentially they got me to remove all Razer software, I had Synapse 2&3 and Cortex, including the mouse drivers and do a complete clean install including a registry sweep.
    Installing the mouse puts Synapse 3 on and I've added Cortex today.
    If its still stable in a couple of days I'll put Synapse 2 back on to get my Razer surround working again and retest again.
  3. 0V3R_K1LL

    0V3R_K1LL Well-Known Member VANGUARD

    Make sure you have clear line of sight with the 2.4Ghz receiver. For me if my PC case is in the way of the receiver my Atheris loses connection sometimes but recovers in 1 or 2 seconds. Doesnt have issues if I use a USB extension and place it near my mousepad.
  4. Vamarelon

    Vamarelon New Member

    Thanks for the suggestion but for testing purposes I'd moved it to my work laptop and tried it on 2.4Ghz and Bluetooth, the same fault had occurred on both. The dongle had a clear LoS and was about a foot away.
    To date since I applied the fixes recommended by support its been stable. I am currently putting on the other Razer software to see if the conflict was eliminated by that fix or if its just an incompatibility.
    I'll keep updating the thread for folks reference as I didn't find anything like it in the forums.
    0V3R_K1LL likes this.
  5. Vamarelon

    Vamarelon New Member

    Here is what Razer support got me to do. Its been weeks and no further issues
    In order to perform a clean install of Synapse 3 and device drivers, please, follow the instructions below:

    1. Open the Control Panel and go to " Programs and Features ". Uninstall " Razer Synapse 3 "
    2. Delete all files in C:\Program Files x86)\Razer\Synapse3 and C:\ProgramData\Razer\Synapse3 directories. These folders are hidden by default, so please be sure to unhide them by accessing " File Explorer Options " on the Control Panel, then, go to the " View " tab and select " Show hidden files, folders, and drives "
    NOTE: If you are unable to delete these folders, you may have to restart your computer first. Restarting will be needed to make sure there are no residual files remaining on your computer

    1. I would like to, kindly, ask you to download a third party program to delete the residual registry entries of Synapse 3. You can search a software able to do this by " registry cleaner ”
    Once you have it installed, scan and clean the residual registry entries

    1. Open the Device Manager and uninstall every Razer product drivers from your computer manually by right clicking on it and selecting " Uninstall device ". Be sure to select delete drivers software as well marking the checkbox when applicable
    Search for Razer devices on the dropdowns " Keyboards ", " Sound, video and game controllers ", " Mice and other pointing devices " and " Human Interface Devices "

    1. Restart your computer again
    2. Make sure you have the latest version of Microsoft .NET Framework. You may download the latest version here: https://www.microsoft.com/en-us/download/details.aspx?id=56116
    3. Download Synapse from the following link: https://www.razerzone.com/synapse-3
    4. Once you have installed it, please, launch Razer Synapse as administrator. To do that, right click on the shortcut and select " Run as administrator "
    5. Log in on Synapse with your Razer ID. Once you are logged in, press on the cog wheel icon on the top right of the window, select " About " and click on " Check for Updates "
    6. Update Synapse and if the software asks you to restart the computer, please, go ahead and restart the computer
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >