Razer Basilisk Hyperspeed X Lift off Distance Problem

Discussion in 'Mice and Surfaces' started by headCoffeeJET592, Aug 30, 2021.

  1. headCoffeeJET592

    headCoffeeJET592 New Member

    Hi there! Yesterday I purchased a brand new Razer Basilisk Hyperspeed X. I'm using it on 2.4 Ghz connection mode, 800 dpi. The problem I have is the very high lift off distance tracking. When I lift my mouse up, it still keeps tracking. This is the video of the problem I'm having: Even with the 3 DVDs high the mouse still tracks. So far I tried: Plugging it to different USB slots, calibrating it over and over and over through razer synapse app. (Tried both smart calibration and all the razer mousepad calibrations although I don't have a razer mousepad.)
    Does anyonelse having this issue and found a solution? Thanks in advance.
     
  2. FiszPL

    FiszPL Well-Known Member VANGUARD

    What mousepad do you have (also color have some importance here).
    Do you have the newest firmware on your mouse?
     
    headCoffeeJET592 likes this.
  3. headCoffeeJET592

    headCoffeeJET592 New Member

Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >