Razer Black Shark V2 X Microphone not working

Discussion in 'Razer Support' started by nexusManateegeo724, Aug 12, 2020.

Thread Status:
Not open for further replies.
  1. nexusManateegeo724

    nexusManateegeo724 New Member

    I just recently bought the razer black shark v2 x and the mic isn't working. Ive tried going into my settings and turning the mic volume up, not only that its not muted. Please help.
  2. DeEmeraldLogan

    DeEmeraldLogan New Member

    mines doing the same thing
  3. Trumptowers8

    Trumptowers8 New Member

    My headset is experiencing the same problem
  4. same here, pls help
  5. ProK9546

    ProK9546 New Member

    I have the same prob
  6. Avalonlk

    Avalonlk New Member

    Same issue
  7. xl_BlindFury_lx

    xl_BlindFury_lx New Member

    I have the same problem
  8. quickDarkBlue068

    quickDarkBlue068 New Member

    I have the same problem
  9. Nekorawz

    Nekorawz New Member

    Well, and so i am......

    Trying on mobile also mic not working
  10. elro3

    elro3 New Member

    I've had an issue like that and just solved it. If it's the same issue, it was solved this way:
    go to Windows Start -> Settings -> Microphone privacy settings and enable it under "allow apps to use your microhpone".

    Apparently windows has privacy settings now, sort of like android. I had no idea.
    Hope this helps someone
    bizCordovanEMERALD344 likes this.
  11. Mrnamir

    Mrnamir New Member

    same problem
  12. I have the same problem, tried everything. Mic works when i plug it directly into pc but not when i plug it into headset.
  13. Pleasant94

    Pleasant94 New Member

    Same thing, mic just not recognized
  14. sunnietimes

    sunnietimes New Member

    I'm having the same issue, I've tried everything Microsoft recommended :/
  15. sunnietimes

    sunnietimes New Member

    I fixed mine after 4+ hours of troubleshooting and customer service!

    I have a PC Windows 10, so I went to settings > update and security > windows update, and then I clicked check for updates and then view optional updates. I expanded Driver updates and selected all of the ones that use/update Realtek. I also had a different, required update, idk if that impacted it. After updating and restarting, the mic somehow worked! This might not work for everyone, but I hope it helps someone :)
    Awlexegrecki likes this.
  16. Awlexegrecki

    Awlexegrecki New Member

    ok so i did this and if it was wrog then it probably wouldve worked my stupid (i am do not want to say the word so here is a replacement) butt had left the mute button on
  17. Totowaler

    Totowaler New Member

    Same issue. The microphone works when plugged into my Android phone but not with a Windows 10 PC.
    Last edited: Feb 17, 2021
    kautif likes this.
  18. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi there! Do you also use the Razer Blackshark V2 X? Ensure to select your headset in the Windows sound's recording tab and set it as default. Go to Start > Settings > Sound, scroll down to the Input section, and click “Troubleshoot”. Let Windows identify the problem, accept the recommended settings change, and try again. Let me know if it helps. Should the issue persists, please send me a PM together with your device's serial number. Let's continue from there. I'll be locking this thread now.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >