Razer BlackWidow Chroma keyboard problem. Not able to type at all.

Discussion in 'Razer Support' started by MEEXXX, Oct 10, 2018.

  1. MEEXXX

    MEEXXX New Member

    Last night keyboard was working fine, today I turned my PC on and I cannot type with my keyboard.

    Things i've noticed:
    - BlackWindow Chroma AND Mamba not showing in Synapse.
    - Device manager showing the "!" next to some keyboard and mouse devices.
    - Might of been a windows update.
    - Keyboard LEDs works
    - Keyboard works in BIOS
    - Keyboard works on other PCs

    Things i've done:
    - Restart PC (almost every time after i do one of the things below)
    - Changed USB ports
    - Update Synapse
    - Run Win10 updates
    - Tried updating drivers in device manager
    - Uninstalled Synapse + delete devices in device manager + delete all razer folders in c:\programfiles x86 and c:\programdata + restart PC + reinstall Synapse
    - Uninstall Windows 10 updates that installed in the last 24 hours.
    - Hold down esc + caps lk + m5 and plug in keyboard.

    Any help would be great. Let me know if i'm missing any information.




    Last second edit:
    - no keyboard i plug in work.... may not be a razer problem. But still going to post just in case someone can help.
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello! Can you share a screenshot of your Device Manager window so we can take a clearer look?
     
  3. MEEXXX

    MEEXXX New Member

    Thanks for getting back to me.

    Attached is screenshot of DM, let me know if you need anything else.
    Only 1 Blackwidow and 1 Mamba connected to the PC.
     

    Attached Files:

    • d.PNG
      d.PNG
      File size:
      50.2 KB
      Views:
      9
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the photo. I sent you a PM. Let's continue there.
     
  5. Hi, I'm having the same problem, except I'm not showing any issues in DM, or anywhere. I've, uninstalled driver, reinstalled driver, tried on multiple computers, Mac and PC. Keyboard lights up, but will not type anywhere.
    Were you able to get it fixed?
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >