Razer Blackwidow pressing random key

Discussion in 'Razer Support' started by retroRifleGreen604, Oct 10, 2018.

Thread Status:
Not open for further replies.
  1. retroRifleGreen604

    retroRifleGreen604 New Member

    My blackwidow chroma keyboard has randomly started to press keys, mainly the f11 and f12 button, but some random ones mixed in.

    I have uninstalled the drivers, uninstalled synapse v2 and reinstalled it, tried v3 beta, cleaned my keyboard, restarted my computer, added and removed profiles and macros in v2, and used different usb 2 and 3 to try to get it to work.

    I have tested a different keyboard to make sure it is the blackwidow.

    It also has certain keys glowing a different color.
    https://i.gyazo.com/d0f15dce0d090178d82c9e074241b021.jpg
    [​IMG]
     
  2. FatKidWanderer

    FatKidWanderer Well-Known Member

    Hola, @retroRifleGreen604! Can you try to uninstall the Razer Synapse to see if there's a difference? Have you tried to plug the keyboard on another computer?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >