Razer Blackwidow Stealth 2016 no proper 'Effects configurator' support

Discussion in 'Keyboards' started by SquidTrooper, Sep 1, 2016.

Thread Status:
Not open for further replies.
  1. SquidTrooper

    SquidTrooper Active Member

    Hello everyone!
    I haven't posted here in a long time :stuck_out_tongue_winking_eye:

    But I felt this was something that needed to be posted here.

    So to start this story, I had a minor problem with the typing on my old 2014 blackwidow stealth, I contacted razer support and they sent me a new, 2016 edition one. Brilliant support from Razer.

    However, there was a bug that caused the effects configurator to stop working, it would say on where the keyboard should be on the configurator 'Image failed to load' and whenever I tried to interact with most things on the window, it would simply crash. Image: https://gyazo.com/70bd14da7b91aa105d01c2feff012e33

    I tried googling the issue and found a fix for the 'Image failed to load' bug, but it would still crash when I tried to interact with it, rendering the configurator useless.

    The fix surprised me. It turns out that most of the files for the Razer Blackwidow Stealth 2016 are not present. If you go into the directory C:\ProgramData\Razer\AdvancedBWU2016\Resources\Devices you will see that there are no files for the Razer Blackwidow Stealth 2016. This is a big issue. Image: https://gyazo.com/21a30de0865b040e496296f9897d3650

    tl;dr: Effect configurator doesn't work for Razer Blackwidow Stealth 2016.

    Razer, pls fix.
     
  2. RaptureHearts

    RaptureHearts Gamer Geek Girl

    I'm not sure if you have already have but remember to let our software support team know about this. You can let them know by hitting the "gear" button on the top-right and hitting "submit feedback" and our software support team will get this checked out.
     
    SquidTrooper and Vaypron like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >