Razer Blade 14 AMD - Touchpad doesn't work

Discussion in 'Razer Support' started by Eldrynn, Sep 11, 2021.

Thread Status:
Not open for further replies.
  1. Eldrynn

    Eldrynn New Member

    I've recently purchased a Razer Blade 14 AMD (4 days ago), received it the day before yesterday, was very happy with it... Until my touchpad stopped working the next day.

    In short, I've changed some settings for my touchpad yesterday (mainly to disable the touchpad whenever there is a mouse connected, I use a Deathadder Essential if it matters) and now yesterday it didn't work at all (even with all of the cables disconnected).

    Here is what I've tried:

    1. Disabling/uninstalling "Razer Blade 14" in Device Manager (under "Mice and other pointing devices")
    2. Updating drivers for "Razer Blade 14" in Device Manager
    3. Removing all cables and restarting my PC
    4. Fully resetting the PC ("Reset this PC" option, deleted all user files as well)

    After all of these steps nothing changed. Furthermore, whenever I go into the touchpad settings, I do not see any actual touchpad settings but rather just the sensitivity (screenshot attached).

    I've also found this I2C HID device malfunctioning in Device Manager and after googling the hardware ID it looks to be the touchpad (screenshots attached). Tried disabling/uninstalling that one and restarting as well, no dice.

    I've registered a ticket with Razer support, but just wanted to post this here in case anyone has any clue or had anything similar happen. Any ideas?
     

    Attached Files:

    Last edited: Sep 11, 2021
  2. Razer.GuitarScar

    Razer.GuitarScar Active Member Staff Member

    Try to isolate the behavior of your touchpad by following the steps from this link. I'd also appreciate it if you send me the ticket number via PM. That way, I can check what's going on with the case.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >