Razer Blade 15 (2018) dies when unpluged

Discussion in 'Razer Support' started by Sir_Lagal0t, Oct 17, 2018.

Thread Status:
Not open for further replies.
  1. Sir_Lagal0t

    Sir_Lagal0t New Member

    I must say i am a bit sad and disappointed, this is a 2000$+ machine, and under one week it already has a major problem, windows says that it has 99% available (plugged in, not charging). But when you unplug the machine it dies instantly. The power brick has a green light and it is drawing power. The machine works normaly when pluged in. Is there any solution to this problem?
     
  2. FirePenguin

    FirePenguin Well-Known Member

    Hi!

    I saw your post. Does it try to boot up when you power it on using the battery?
     
    freakydoctor likes this.
  3. Sir_Lagal0t

    Sir_Lagal0t New Member

    Thank you for the reply.

    No it does not. There is no sign of life when unplugged.
     
  4. FirePenguin

    FirePenguin Well-Known Member

    I see.
    I sent you a PM regarding this. Give me a reply whenever you can. :)
     
    freakydoctor likes this.
  5. phatpt0311

    phatpt0311 New Member

    Hi Sir_Lagal0t,
    I have same issue with yours my Razer Blade is 46% instead 99% like your case. Did you resolve your issue?

    Regards
    Phat Phan
     
  6. M1ND53T

    M1ND53T New Member

    Can you also pm me since I have a the same problem
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >