Razer Blade 15 Advanced (2018) missing webcam & mute microphone

Discussion in 'Razer Support' started by GR8-Ride, Jun 27, 2019.

  1. GR8-Ride

    GR8-Ride Member

    Guys,


    My 2018 Razer Blade 15 has been a mostly flawless machine over the past 11 months that I've had it, with the exception of two minor issues.

    First of all, sometime in the past few months my Realtek Audio microphone stopped working. Windows 10 still thinks I have a microphone in the laptop, however when using my laptop for any conference calls etc, no sound is picked up at all. I generally use an external Jabra 510 / 710 speakerphone, so it hasn't been a huge issue, and I haven't worried about it at all.

    However in the office this morning, and on a WebEx call and noticed that it says No Camera Detected. This is a first, and while I also rarely use a webcam, it's more than a little disconcerting that my 11 month old laptop is now starting to have these small items fail one by one, especially now that I close in on my 1 year warranty date.

    This is also a machine I use for work, so being without it for several weeks in order to repair is not an option.

    Any chance it's a loose cable or something else that can be fixed readily and quickly?



    Patrick
     
    Ivan_Develos, TA_TA and TiredOracle like this.
  2. whatevereverever

    whatevereverever New Member

    Hi, I actually had the same issue and spoke with Razer's support team yesterday who sent me links to a newer BIOS file v1.07 and a newer EC update Version 1.03. For some reason they are not listed on the Razer downloads page (at least here in the UK) but I was told by the woman on chat that they should sort out most webcam and microphone related issues with the 2018 Razer blade Advanced.

    here are the links

    BIOS update 1.07
    EC Update 1.03
    Obviously backup your data before updating the mainboard. I also reinstalled windows after the updates which may or may not be something that you can do, but is probably a good idea. I also reset the bios to defaults.

    Maybe some more knowledgeable here (hey Razer!) could tell us what the newer BIOS and EC files are actually addressing in full.

    I did notice afterwards that the power saving features in Windows had actually shifted, meaning that to get the same battery life I used to get on the middle setting (Better performance) I have to put it on the lower setting (Better battery).
     
  3. GR8-Ride

    GR8-Ride Member

    So the next obvious question is, did that work for you? As it's not working for me, and I've updated both the EC to 1.03 and BIOS to 1.07.
     
  4. whatevereverever

    whatevereverever New Member

    Do you know what I hadn't actually checked because I don't use either the mic or the webcam. It did seem to resolve my other issue, at least I have not yet had an irrecoverable black screen yet, but only time will tell with that.

    Ok.. you know what, neither the webcam or mic are working. Sounds about right.

    Razer need to release a public statement about these issues, and sort out replacements, I am sure Louis Rossman and Linus tech tips would not be surprised.
     
  5. whatevereverever

    whatevereverever New Member

    By the way, Razer support told me yesterday that we actually have TWO YEARS WARRANTY in Europe not just one which was a pleasant surprise. I am totally with you on this, the Razer Blade is an expensive bit of kit and having them fail so quickly is pretty shoddy.
     
  6. GR8-Ride

    GR8-Ride Member

    Like yourself, I'm not a real user of either the Mic or the webcam, so I'm not really out of sorts about the lack of functionality. Where it becomes an issue for me is the fear of "what's next?". I bought this machine through Microsoft, and have the AMT Performguard extended warranty, so I have 2 years as well. The hassle with warranty repairs is more the concern about being without the machine for several weeks. Maybe I'll just buy myself a 2019 Advanced model with the 2080 Max-Q to use in the interim. :)
     
  7. whatevereverever

    whatevereverever New Member

    lol, yeah was thinking the same but the thing that put me off was well.. what will go wrong with the newer one?

    I don't have a desktop pc at the mo, so the same as you cannot be without a computer for what, 2-4 weeks while they try to sort it out. I noticed that they do some kind of elite support plan in the US but don't think that includes onsite repair and do not know if you can buy it post sale.

    Good luck with it all, hope you get it sorted out
     
  8. Meandro_

    Meandro_ New Member

    I have the same problem,and I tried to update both the EC to 1.03 and BIOS to 1.07.It didn't work at all.
     
  9. GR8-Ride

    GR8-Ride Member

    EC and BIOS updates didn't work for me either, so Razer issued an RMA for me, and I shipped it to their test / repair facility here in Canada. Unfortunately they're out of parts, as apparently they need to replace the entire display in order to fix the webcam & mike. So I'm either out a laptop until they get the parts, or they have offered to ship me a refurbished unit. I actually wish they would have just issued me a credit, and I'd order a new system directly from Razer.com.
     
  10. TA_TA

    TA_TA New Member

    Any update on this issue ?
     
  11. coffeejunk

    coffeejunk New Member

    Just updated the BIOS and the driver, no result...
     
    Antiker377 likes this.
  12. Senor.elToro

    Senor.elToro New Member

    I've now been in the same boat (2018 Razer Blade Advanced) for the second time. The first time around, I went back and forth with Razer support until I sent the device in for RMA. After I got my device back, it worked fine..for five months, and now I'm having the exact same again. Now I'm back troubleshooting with Razer support.

    They never told me precisely what the problem was last time, but it looks like they replaced the entire display (as Meandro_ experienced). It seems like it's some kind of hardware failure with the display housing or the cable. It's concerning that the replacement displays may be just as prone to the same failure.
     
    Antiker377 likes this.
  13. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hi everyone! Thanks for posting your concerns here. Please send me a PM should you still need further assistance.
     
    rebel_of_steel likes this.
  14. Linhtt23

    Linhtt23 New Member

    Same here with my blade 15 advanced 2018. So sad
     
    Senor.elToro likes this.
  15. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hi there! Please send me a PM together with your laptop's serial number so I can assist you right away.
     
  16. Antiker377

    Antiker377 New Member

    I am experiencing the same issue. My webcam stopped working all of a sudden.
     
  17. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey there! Thanks for sharing. Please send me a PM. Let's continue from there
     
  18. Senor.elToro

    Senor.elToro New Member

    Check to see if your mic is cooked too. If so, my guess is that it's the same issue I experienced and you'll need to send it in for servicing. I've had this problem three times now, so it seems like it's pretty common for this make/model. Out of curiosity, is yours the black model or the silver one?
     
  19. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey everyone! Feel free to send me a PM should you need additional assistance.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >