Razer Blade 15 Advanced (2018) webcam not found

Discussion in 'Razer Support' started by autoCoolBlackcounty326, Oct 5, 2020.

Thread Status:
Not open for further replies.
  1. Hi,

    I have a Razer Blade 15 Advanced (2018) model and over the weekend I found the built-in camera was not detected by Windows. I checked "Device Manager" and the camera was not on the list. I tried a few common checking steps (checking Windows updates, resetting camera, etc), but was not able to get it work. I suspect this could be due to some hardware-wise issue. Does anyone have any idea on how to fix it?

    Thank you!
     

    Attached Files:

    NobNob1018 likes this.
  2. ladyskiller827

    ladyskiller827 New Member

    i have same case with you , And i didn't have idea to fix it!.
    Wait for Help!. :slightly_sad:
     
  3. NobNob1018

    NobNob1018 New Member

    Up to your post! also experiencing the same problem and tried a lot of ways to troubleshoot this. Hope this gets noticed
     
  4. bicyclethink420

    bicyclethink420 New Member

    #MeToo... What's up Razer? No support!?
     
  5. bicyclethink420

    bicyclethink420 New Member

    "Camera not found" cant see it in the device manager either... ///Mattias
     

    Attached Files:

  6. Carter_Kane

    Carter_Kane New Member

    Tried uninstalling the driver to no avail since they didn't upload an integrated webcam driver on the razer support website. Scanning for hardware changes, updating, troubleshooting, and restarting didn't help in fixing the camera.
     
  7. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Please go to your laptop's BIOS main tab and check if your BIOS version is on 1.08 and the EC firmware on 1.02. If it's outdated, please download the firmware by clicking this link. Should the issue persist, please submit a case to our Support Team by clicking this link. Else, send me a PM so I can assist you in creating a support case.
     
  8. silviafernandez

    silviafernandez New Member

    Hi @Razer.SpeedCr0ss, I was trying to send you a DM, but the forum keeps complaining that I don't have access. :frown_:

    I'm suffering from the same issue, I've checked and both versions seem correct. Could you give me a hand?
     
  9. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Sorry for the late response. By the way, I've sent you a PM. I'll wait for your follow-up.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >