Razer Blade 15 Advanced BIOS Update Hangs

Discussion in 'Razer Support' started by Sugik, Apr 18, 2019.

Thread Status:
Not open for further replies.
  1. Sugik

    Sugik New Member

    Tried installing the BIOS V0104 but it hangs at 99%. I left it to install for a couple of hours and tried multiple times but no solution. Saw other people on reddit having similar issue. Help!
     
  2. 2RCR_VRI

    2RCR_VRI New Member

    Hi Sugik,

    I have ran into the same issue. I recieved my Razer Blade 15 2019 on 11 Apr 2019. The first thing I tried was updating the BIOS to BIOS Ver. 0104, but it just hangs at 99% and like you I left it for a couple of hours.

    So I contacted Razer Support.

    This is the first email that I received after getting of the phone with support. he was really helpful.

    1st. April 11, 2019
    Thank you for contacting Razer Support. We are happy to assist you.
    Terribly sorry for any inconvenience that you have experienced while updating your Razer Blade 2019 Advanced BIOS.

    We were able to resolve the problem but interrupting the BIOS update. However, in order to make sure that there is nothing wrong with the device, please run some test on it. All EC and BIOS updates should be put on hold until further notice just to be on the safe side.

    This was the follow up I sent on April 14, 2019

    Hi,
    I know when I tried to update to the latest BIOS ( http://drivers.razersupport.com//in...ownload&downloaditemid=3157&nav=0,350,860,864), it stopped between 98-99%. I let it continue for a couple of hours before I decided to call Razer Tech Support.
    Just wandering when the next BIOS will be released.

    Reply from Support April 15, 2019
    We have already relayed this to our development team and as of this writing they are still looking into solutions on how the problem can be addressed.

    In relation to this, we would like to ask that you bear with us on this case, We will make sure to notify you once the update freezing has already been address.
    Thank you for your continued patience.

    Now we wait for an update.
     
  3. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello there! Are you still having this issue?

    Hi! Can I have the case number so I can take a look? Please send it over through PM. Include the link to this thread as well as a reference. I'll pick it up from there.
     
  4. fchixon

    fchixon New Member

    I am having the same problem. The EC update worked fine, but the BIOS one completes but never reboots and the BIOS is never updated.
     
  5. fchixon

    fchixon New Member

    Mine worked finally. I followed someone else in the forums instructions on unzipping the updater and running the command line BIOS 1.04 update and it works. This is what I hate about windows machines. Why can't intel and Microsoft get it together and have one patch that updates things instead of this stupid multiple patches in specific order to make things work. I just hope this fixes my daily nVidia driver based crashes. The Apple Macs I manage are SO much easier since the updates just work and the machines just work. Not gaming machines, but workhorses that don't ever seem to crash.
     
  6. Sugik

    Sugik New Member

    Can you tell me where to find the instructions?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >