Razer Blade 15 base unable to update to win 10 version "1903"

Discussion in 'Razer Support' started by Phil-adelphia94, Jul 26, 2019.

  1. Phil-adelphia94

    Phil-adelphia94 New Member

    Hi,

    Recently, the Windows 10 May 2019 "version 1903" appeared in Windows update for me to download and install. However I'm unable to update the OS.

    It says the problem is with the Intel Rapid Storage Technology drivers, however after updating the drivers and trying again, it is still giving me the same message.

    I'm not sure what to do now. Have I've been missing something?

    Thank you in advance

    Phil.

    EDIT: I found a solution in another forum.
    You can rename the file of the driver to make it "invisible" to the updater, like "iastora.sys_X" for example. Once the update has finished, you can change back to the original name.
    I noticed that when hovering over the file of the driver, it was still and old version. It did not update itself to a new one when I updated it.
    The file can be found in system32\drivers directory.
     

    Attached Files:

    Last edited: Jul 27, 2019
    mhanixseares and CHEATERSAM like this.
  2. Monster.Shooter

    Monster.Shooter New Member

    Hello,
    I have the same problem.
    Possible to have help ???
    Cordially
     
  3. HeronCalaris

    HeronCalaris New Member

    I have the same issue on a Razer Blade Stealth (2019) , I've tried installing both the newest version of the Rapid Storage Technology and the recommended "15.9.6.1044" version and I am still getting blocked for the update.
     
  4. Phil-adelphia94

    Phil-adelphia94 New Member

    Same here, I tried installing the recommended version but I couldn't do that also.
     
  5. Gaz60

    Gaz60 New Member

    Same here... 15'' base model.
    I updated all of intel's drivers as well but the RST was not part of the update:
    upload_2019-7-27_9-23-55.png
    Does anyone have an idea of how to fix it?

    EDIT: Was able to make the update!
    I followed this guide:https://appuals.com/fix-intel-rst-service-not-running/
    And I saw that my service was not working on the startup. In the end, I went thought all the options to fix this issue and was able to update. Not sure which option did it.
     
    Last edited: Jul 27, 2019
  6. Phil-adelphia94

    Phil-adelphia94 New Member

    I followed the guide, but i'm still getting the error/message. Everything involved with the RST was working correctly so I don't know what te problem may be.
     
  7. Monster.Shooter

    Monster.Shooter New Member

    every time I try to get one of the Intel RST driver versions and try to open the executable, I get an error saying "Setup has ended prematurely because of to the following error: This platform is not supported.
     
  8. Phil-adelphia94

    Phil-adelphia94 New Member

    I have found a temporary solution. See the edit of my original comment. Hope it works for you too!
     
  9. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi everyone! Thanks for posting your concerns and best practices here. This is quite odd and needs investigation. Please send me a PM together with your laptop's serial number should you need further assistance.
     
  10. Last edited by a moderator: Aug 3, 2019
  11. Monster.Shooter

    Monster.Shooter New Member

    Same for me
     
  12. Razer.Speedcr0ss likes this.
  13. Monster.Shooter

    Monster.Shooter New Member

    how to update Intel® Rapid Storage Technology (Intel® RST) ???
     
  14. HeronCalaris

    HeronCalaris New Member

    Okay so everyone whose system says that their platform is not supported follow these steps
    1. Go into boot menu (f12 when booting up the computer)
    2. go into the chipset menu
    3. go into Data and RST configuration
    4. go into Sata mode selection
    5. Change AHCI to Intel RST
    Hopefully we have the same boot menu and this should let you install the latest Intel RST drivers from the Intel web page. After that then do what Phil-adelphia94 did with his old iastora.sys file and windows should let you update. At least it did for me.
     
    illathon and Razer.Speedcr0ss like this.
  15. Monster.Shooter

    Monster.Shooter New Member

    Hello everyone,
    Phil-adelphia94 solution tempts me well but I do not want to do anything because I have my computer since July 17, 2019. I had Razer.Speedcr0ss in MP but to this day I have more news .
    Thank you all for your help
    PS: sorry for the translation I am French
     
  16. MrRobot222

    MrRobot222 New Member

    Why is there no fix from Razer? Just bought my laptop and I'm stuck on 1803.
     
    polydev likes this.
  17. illathon

    illathon New Member

    This answer needs to be stickied at the top.
     
  18. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi everyone! At this time, legacy Razer Blade units may run into a situation where they are unable to properly update to Windows 1903. Almost all of our units are affected aside from our previous Razer Blade Pro 17" 2016 and 2017 that are shipped with RAID configuration which requires Intel RST driver and its component. Our engineering is aware of it and currently working on a fix. By the way, for all non-Razer Blade Pro 17" 2016 and 2017 models, we recommend renaming the iastora.sys to iastora.sys.old which is located under c:\windows\system32\drivers path before running the Window update. Otherwise, please wait for our fix. We appreciate your patience.
     
  19. DaiBach99

    DaiBach99 New Member

    Renaming iastora.sys worked for me, no BIOS changes needed.

    Thanks.
     
  20. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    That's good to know! Feel free to send me a PM should you need further assistance.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >