Razer Blade 15 base unable to update to win 10 version "1903"

Discussion in 'Razer Support' started by Phil-adelphia94, Jul 26, 2019.

  1. https://insider.razer.com/index.php...-allow-windows-1903-update.50998/#post-498118

     
  2. RaginKnight

    RaginKnight New Member

    Im having the same issue..
     
  3. jobocrawe

    jobocrawe New Member

    after i rename, i update and then do i restore the file name back to iastora.sys?
    also the official fix, do i get prompted automatically for this or i have to manually download this from somewhere?
    sorry i am not familiar...i just bought my laptop weeks ago....
     
    polydev likes this.
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for asking! You can leave it as "iastora.sys.old" for now, while we are working on the official/final fix. We'll keep everyone posted.
     
    polydev likes this.
  5. polydev

    polydev New Member

    In the meantime, Microsoft is not longer attempting to download 1903 and Windows Update has reverted the Update on my Blade Advanced 15 to this status:

    The Windows 10 May 2019 Update is on its way. We're offering this update to compatible devices, but your device isn't quite ready for it. Once your device is ready, you'll see the update available on this page. There's nothing you need to do at this time.
    which may have coincided with the Synapse 3.1.627.5 update (not sure, but timing seems about right). That's progress, at least.

    Very eager for an official fix from Razer!
     
  6. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for sharing. Feel free to send me a PM should you need further assistance.
     
  7. nonstopoperation

    nonstopoperation New Member

    Hi, sys.old fix doesn't work here.

    Mine is a 2017 Razer Blade Stealth I7-7500u (RZ09-01962).

    Where will the fix be announced and any update on when?

    Also I would like to update the recent intel security patches. Can you confirm if this can be done without updating windows from 1803 as the documentation suggests it can't
    https://dl.razer.com/master-guides/Blade/Intel ME Updater_v1.1.1.2.pdf
     
    Last edited: Aug 22, 2019
  8. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! We are currently waiting for our final fix and its ETA at the moment. We'll get back to you ASAP. We appreciate your patience.

    Hi @nonstopoperation. Please send me your laptop's serial number via PM, let's continue from there.
     
  9. Kainzaah

    Kainzaah New Member

    Has anyone succeeded after the today's update?

    After the Razer Synapse update I tried the Windows update, it started installing the 1903 version, but failed (with an error). I tried again, but then it didn't detect any updates and I still see the information that my device is not ready for 1903.

    Razer Blade 15 (2018 Basic)
     
    polydev likes this.

  10. I didn't know there was a Synapse update that was supposed to address the Windows update issue. Where did you see that announced?
     
  11. Kainzaah

    Kainzaah New Member

    The Official Support posts say that they are working on a fix and in their post no #24 they say
     
  12. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey. I made a correction to my post. I will let our Developers work on the fix and do the final announcement. Sorry for the confusion.

    Hi everyone! Send me a PM should the issue persists, so I can provide you with some workarounds.
     
  13. jknochin

    jknochin New Member

    Wait, this for real must be a joke. I dropped 3 grand on a laptop that can't even update to the MAY version of windows? I have the advanced mi-2019 model and still have this problem.
     
    polydev likes this.
  14. 31580

    31580 New Member

    We have to see if all the drivers and all the .dss files are updated or not. The kernel in the latest windows system may create some problem causing this issue, this issue will be resolved with updates from the windows. I had help from www.facebook.com so that this solution can be resolved.
     
    Razer.Speedcr0ss likes this.
  15. Savagely_Rekt

    Savagely_Rekt New Member

    FYI renaiming iastora.sys did not work for me. Update hung at 48%. Had to revert.


     
  16. l4v4l4mp3

    l4v4l4mp3 New Member

    For me it worked fine early this week.
     
  17. polydev

    polydev New Member

    Update for everyone: Microsoft released update KB4512941 which fixes the instability in 1903 that having the old Intel RST driver caused.

    This fix means that you do not need to remove/alter/your iaStorA.sys driver.

    Within 48 hours, those of us who are affected by the iaStorA.sys problem should be able to upgrade to May 1903.

    To quote Microsoft, see the "Next Steps" of the KB article describing the Intel RST issue, which was added yesterday, 9 September:

    This issue was resolved in KB4512941 and the safeguard hold has been removed. Please note, it can take up to 48 hours before you can update to offered Windows 10, version 1903.
    (My update still hasn't appeared, but it's still less than 48 hours.)
     
  18. Savagely_Rekt

    Savagely_Rekt New Member

    It became available for me yesterday through windows update. The update stalled and sat for 4 hours at 27% after rebooting. TL;DR: It did not work. (blade 15 advanced mid 2019).
     
  19. mhanixseares

    mhanixseares New Member

     
  20. polydev

    polydev New Member

    My final update. I finally got Windows 10 Pro 1903 (build 10.0.18362) installed on my Razer Blade Advanced 15 late 2018!! :trophy:

    Note: For anyone coming to this thread late, with KB4516058 you do not need to touch your iaStorA.sys drivers.

    If you have third-party anti-virus, you might experience problems: just disable it temporarily.

    If this helps anyone, this is what I had to do:
    • Eject all your external hard drives and unplug them
    • Unplug all your peripherals except the power cable (yes, external monitors, everything!)
    • Open a Powershell console as Admin, and check that your Windows Update registry is healthy and up to date with
      • dism /online /cleanup-image /restorehealth
      • This might take a long time or look like it's stalled at 100%, just wait!
    • Then check that your filesystem integrity with
      • sfc /scannow
      • This ming take a long time, too, or look like it's stalled at 100%, just wait!
    • Download the update manually from https://www.microsoft.com/en-ca/software-download/windows10
    • Quit all your running apps, including Synapse
    • Run the updater
      • It will take a long time, perhaps look like the download stalled, or an install phase stalled. Just leave it.
      • Mine failed with a 0xc0000005 error several times; just retry.
    Came home to a "Hi" windows update message and the attached screenshot after setup (as proof).

    Then, go run Windows Update > Check for updates to make sure you have the latest KB patches for your newly-installed 1903.

    I don't have any negative side-effects I've seen in the news, like Night shift stuck at full redness. Everything seems fine to me.

    Good luck everyone!

    References:
     

    Attached Files:

    Last edited: Sep 11, 2019
    Savagely_Rekt likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >