Razer Blade 15 Multiple Problems

Discussion in 'Razer Support' started by SuperChicken566, Mar 5, 2019.

Thread Status:
Not open for further replies.
  1. SuperChicken566

    SuperChicken566 New Member

    Hey everyone,
    Through my school I was given a Razer Blade 15 with the 144 Hz screen and no touch. Throughout the school year I have come into contact with many problems that i need help with.

    1. The microphone suddenly stopped working. I have gone and looked through the device manager, removed devices then scanned for them again but to no avail it is still busted.

    2. The camera stopped working. Again, I've done the whole song and dance with the device manager

    3. The logo suddenly stopped lighting. I have changed the lighting settings so I don't think its that.

    I have the latest drivers for both windows and synapse (minus the mining software). Is there anything I can do before taking it into my schools repair center because it will set me back a few days on my work.

    Thanks y'all,
    SuperChicken
     
  2. wangxiaoshang

    wangxiaoshang New Member

    Same problems here.
     
  3. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there guys! Can you send over the serial number of your Blade to me through PM? Please include the link to this post for reference. Let's continue there.
     
  4. I have the mic and camera issues too.
    My logo on the other hand wont stay off!
     
  5. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! I already sent a reply to your PM. Let's continue there.
     
  6. We already have a conversation going from another post.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >