Razer Blade 15 Ubuntu 18.04 poor wifi performance fix.

Discussion in 'The Linux Corner' started by after-life, May 29, 2018.

Thread Status:
Not open for further replies.
  1. after-life

    after-life New Member

    After fresh 18.04 install, wifi performance was very poor. This seems to fix the issue:
    Code:
    sudo modprobe -r iwlwifi
    sudo modprobe iwlwifi 11n_disable=1
    This will only temporarily fix the issue. To make the changes persist:
    Code:
    echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
    Link to the original article:
    http://cachestocaches.com/2016/1/disabling-ubuntus-broken-wi-fi-driver/

    Hope this helps!
     
    FizzyChicken and parzevil like this.
  2. mgarciaa

    mgarciaa New Member

    Great... thinking of buying the 15 version for Ubuntu/CUDA and Machine Learning tasks...
    Do you have any issues with Ubuntu? Thanks!!!
     
  3. after-life

    after-life New Member

  4. FizzyChicken

    FizzyChicken New Member

    That's fantastic. I've been struggling with wifi with some routers with my late 2016 Blade. That seems to have fixed to issue. Thank you.
     
  5. FizzyChicken

    FizzyChicken New Member

    Spoke too soon there... when I added that line to iwlwifi.conf things broke down pretty bad. The strange thing is that I only get problems with certain routers... namely the one I have at home. When I'm on work or connected to another router wifi works fine.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >