Razer Blade 15 WiFi Issues

Discussion in 'Razer Support' started by ConfessedSpace3, May 7, 2019.

  1. ConfessedSpace3

    ConfessedSpace3 New Member

    Hello All,
    I purchased a Blade around March 2019 and I have been happy with the product overall except for one large issue that I have had on the computer. It will consistently drop the connection to my WiFi network every two to five minutes if I am not playing a game. I will lay out all I have and what I have done.

    Laptop Specs:
    Razer Blade 15" Gaming Laptop
    15.6" Full HD 1920 x 1080 60Hz
    8th Gen Intel Cor i7-8750H Processor, 6 Cores
    Mobile Intel HM370 Chipset
    NVIDIA GeForce GTX 1060 Max-Q
    16Gb Dual Channel SO-Dimm
    128Gb SSD + 1Tb HDD
    Windows 10
    Intel Wireless-AC 9260 IEEE 802.11a/b/g/n/ac & Bluetooth connectivity

    My WiFi is provided by Spectrum.
    The router/WiFi unit is: Arris TG1672G
    Band: 5 GHz

    What I have done:
    Contacted Razer Support where they instructed me to uninstall the Wireless Ac network adapter and reinstall it. I did so and it helped for a period of time so I thought it was gone. It started dropping the WiFi right after the window to respond was closed.

    I opened up another inquiry to try and see if other solutions were available where they instructed me to reset the blade to factory default. This process will wipe the drive. I have Solidworks Student Edition 2018-2019 installed on this computer and I cannot wipe the drive because I will lose the Solidworks license and I cannot get another one. I do not know if I can move this program to an external drive and I also know that I do not have an external drive large enough to move the program onto (if it can be done). So I did not reset the computer to the factory default.

    I then proceeded to try and see if I could fix it myself and opened up the properties of the network adapter through the device manager. I opened up the properties of the Intel Wireless-AC 9260 by right clicking on it and opened the advanced tab. Now I can see the Properties and the Value that it is reading; it is currently set on dual band 802.11a/b/g, 802.11n (which I changed from Auto), and the rest I did not look at or change.

    The change from auto to the 802.11n seemed to help for a time but it has fallen off and is back to losing the WiFi. When I go to connect (as the computer is newly booted in the morning or anytime after it drops) the WiFi will frequently tell me: Cannot Connect To This Network. I will have to try multiple times to connect and then all of a sudden it will connect. It makes no sense to me.

    Further details on when it drops the WiFi is what puzzles me to no end. I can play World of Tanks for hours with no problem. It will never drop the WiFi during any gaming session that I do. As soon as I close a game and open up YouTube afterwards (which for me is common since I stream music off of it) it drops the WiFi 30-40 seconds into the video. I then have to disconnect, reconnect and then I get two or so minutes of no interruptions and then it drops again. I will then stop watching YouTube on my Blade and try to Google problems and it will not drop the WiFi. It only happens while streaming video as far as I can tell. It also does not matter what platform I watch the video on; Internet Explorer, Firefox, or Chrome. Note: I have to keep the WiFi from automatically connecting on my network which also seems to help (seems counter intuitive but auto connect has failed far more often than being manually connected).

    If anyone has any tips on what could be causing the connection to drop while streaming YouTube then I would really love to know because it is extremely frustrating.
     
    Woloshyn022 likes this.
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! I'd like to take a look at your case. Can I have the case number? Please send it through PM. Let's continue there.
     
  3. Woloshyn022

    Woloshyn022 New Member

    I have the 2070 Max Q and 512 GB SSD configuration and have been experiencing extremely similar issues. For the first few weeks, I could not pinpoint if the issue was local to my device, or a problem with my ISP, but I can confirm after a few weeks of testing/ trial and error, that these connectivity issues are local only to this device.

    I have not contacted customer support because I was hoping I could find a solution to the problem without having to deal with the myriad hoops you need to jump through to actually be helped. That being said, I have also tried all troubleshooting that the OP has tried, as well as changing the setting in Intel Wireless-AC 9260 power management, "Allow the computer to turn off this device to save power", to False by unchecking the box. Nothing seems to work which leads me to believe the issue is hardware based and not software based.
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Can you send over the serial number of your Blade to me through PM? I'll help you out through there.
     
  5. Woloshyn022

    Woloshyn022 New Member

    I now haven't been experiencing issues for the past few days... So now my assumption again is that my internet is bad. If anything changes I'll be sure to reach out again, but thank you for getting back to me!
     
  6. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the update. Just let me know if you need more help.
     
  7. Critical_Wing

    Critical_Wing New Member

    I am also having problems with the WiFi, my iphone can get 60-90Mb/s out of the local wifi connection but the most the Razer Blade will manage is 3-4Mb/s and this is intermittant.

    I also have problems with the Bluetooth not finding any devices. Not sure if they are related, laptop less than month old.
     
  8. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Please send over the serial number of your Blade to me through PM. I'll assist you from there.

    Anyone else having the same issue, please send me a PM as well.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >