Razer Blade 15 won’t turn on

Discussion in 'Razer Support' started by TeethRocket, May 25, 2021.

Thread Status:
Not open for further replies.
  1. TeethRocket

    TeethRocket New Member

    Razer Blade 15 (base) 2018

    TL;DR: battery stuck at 0% no matter what

    Backstory: computer was running just fine with 2 hours of battery left (in reality probably more like 40 mins) then I left and came back, brought it out of sleep mode and the red light was on with it saying very low battery. I plugged it in and everything seemed normal except the red light was on, it didn’t say it was charging, and the battery said 0%. I left it charging and then unplugged it and it was running fine on battery for 20 mins before I restarted it (still said 0%.) I assumed it was a software issue that it shuts the computer off with some reserve battery based on what it thinks the battery life is so you don’t lose any data if it dies. At this point, I can’t do anything with it unplugged or plugged in. Instantly shuts off as soon as it starts to boot.

    What’s going on here and what can be done?
    The battery does not look swollen
     
  2. TeethRocket

    TeethRocket New Member

    Update: I just turned it on and it went through several repairs and is now working like normal…we’ll see if this lasts
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for updating your thread. You can follow the steps from this link too should the issue happens in the future. I’ll be locking this thread now. Feel free to send me a PM anytime or visit our self-help options should you have other questions or concerns.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >