Razer Blade 17 Pro 2020 black screen

Discussion in 'Systems' started by pitha1337, Jul 20, 2020.

  1. pitha1337

    pitha1337 New Member

    Hi everyone,

    when unplugging the power cord when in "dedicated graphics card only mode" my screen goes black and can only be revived by plugging in the power cord again. Can someone please confirm this issue?

    Model: Razer Blade 17 Pro, 300Hz, RTX 2080 Super
     
  2. pocket_geek

    pocket_geek New Member

    Same here, it appears to be a driver issue with the latest version of Windows 10 coupled with the latest Nvidia driver. It doesn't appear to be a hardware problem since older drivers don't exhibit this problem
     
    pancholr likes this.
  3. pitha1337

    pitha1337 New Member

    Thanks for your reply. I also found out that with Windows 10 Build 2004 the screen stays black even when the power cable is connected. Had to revert back to the older build.
     
    pancholr likes this.
  4. Kaitokid021

    Kaitokid021 New Member

    JulianKapa likes this.
  5. pocket_geek

    pocket_geek New Member

    I'm not sure I buy this. Why would a driver update require a bios update to fix?
     
    dingalongathon likes this.
  6. Kaitokid021

    Kaitokid021 New Member

    I don't know either it seems they are all pointing each other call a cusotmer service from razer they point out its microsoft issue, nvidia said that its a different issue from microsoft and nvidia problem that razer need to update bios not sure why, Microsoft halted the update on devices that has problem. I reverted my razer blade to windows build 1903 I think the one that came with the factory and it seems that the windows build 2004 will not show up on me anymore on windows update my guess is they blocked the razer blade from getting it until this issue is fix maybe. Reverting to my factory build fixes everything though so Im happy with it, I can enjoy my blade now without issue
     
  7. dingalongathon

    dingalongathon New Member

    Hate to say it, but 2004 showed up for me on a blade 17 and stealth, the stealth updated fine and ive had no issues, but the blade 17 has the same issues as above, even now after a few weeks has past. Is anyone even working on a fix for this? Doesnt normally take this long to fix such a basic issue.

    If you arent aware, microsoft has a history of rolling out updates that break things, ive worked in IT for over 20 years and we are all terrified of microsoft updates, we know how much time is likely to be needed to fix things they change. In my experience they always blame it on the manufacturers, however I have good access to a lot of manufacturers and they are able to show a different story, most of the time ive seen things like microsoft wanting to do things a different way which they know will cause issues for a lot of people, but they do it anyway and expect the manufacturers to pick up the pieces. How many times has microsoft rolled out a bad update or in some instances the updates have ruined equipment for one way or another. Its really not acceptable but sadly they have the monopoly until software developers take linux more seriously.

    So painful to not be able to use hardware GPU scheduling (yes i know its pretty pointless and often affects game performance negatively) and the other "fixes". Its safe to say, if its not broken, dont try and fix it. For me, going forward, its security updates only until these service packs have been out and tested for months. Just in case anyone is frustrated by the autoupdating nature of windows 10, you can download a small program from microsoft ( i havent used a link as im not sure if this forum allows it but a google will find it quite easily) which can disable selected updated from being installed, for some reason microsoft have removed the capability from windows directly. So not only do they roll out bad updates regularly, but now they also make it even harder to stop it from happening.

    Oh well, yet another bad update from microsoft, like anyone is shocked by that! I think microsoft have to realise that not everything can be pushed onto the manufacturers, on this occasion the issue is caused by something that could have been avoided.

    Rant over :)

    Chris
     
    JulianKapa likes this.
  8. pitha1337

    pitha1337 New Member

    JulianKapa and Americo94134 like this.
  9. pitha1337

    pitha1337 New Member

    Finally fixed!

    Installed the BIOS 1.04, updated to Windows 10 2004 and downloaded the most recent NVDIA driver (had to download it manually from NVIDIA website). Now the black screen is gone.
     
  10. sergeantash

    sergeantash New Member

    This hasn't solved the issue for me, Razer 17 Pro - booting up I get a black screen, if I hold power button and restart then screen works...shutdown and restart and black screen again - so annoying for a 4000 EUR laptop...
     
    Licoricetrendauto117 likes this.
  11. TheParadyme

    TheParadyme New Member

    Can you try installing the 452.06 version of Nvidia drivers? For me I'm using this one as the newer ones had some issues on my RBP 2020 with external screen, and at least one of the displays being dark, fixed sometimes by rebooting.
     
  12. clubSeaBlueeasy904

    clubSeaBlueeasy904 New Member

    I got a similar issue on my 2020 Razer Blade Pro 17 with 2070 with Max Q. I need to plug in my power cord to avoid black screen if my laptop is on Dedicated GPU only. I downloaded this latest BIOS version 1.04 and it did solve my problem. I don't have a black screen at all after BIOS update and restart.
     
  13. dudepare01

    dudepare01 Member

    You have to choose with that black screen or losing the ability to undervolt by updating your Bios. I hope someday they would allow us to undervolt (to a certain amount) or at least apply a stable undervolt on future bios updates for the 17
     
  14. Remy.Vandenheuvel

    Remy.Vandenheuvel New Member

    ive the same problem, when booting up sometimes also a black screen . razer fix this problem so much people have this problem !!!!
     
  15. Remy.Vandenheuvel

    Remy.Vandenheuvel New Member

  16. rjkrejci

    rjkrejci New Member

    I had to go back to 452.06 version of Nvidia drivers...no black screens since. V1.04 bios on 17 Pro 2020
     
  17. Remy.Vandenheuvel

    Remy.Vandenheuvel New Member

    I will try it, thank u so much
     
  18. Remy.Vandenheuvel

    Remy.Vandenheuvel New Member

    I doesn’t work at all. I updated the bios to 1,4 and the Nvidia driver to 452.06 and I have still the problem. Does yours have it also if u close the screen when it’s on and than opening it again. At my razer blade it gaves u a black screen and also at the first boot also
     
  19. rjkrejci

    rjkrejci New Member

    Bummer...yes, mine would black out when it awoke from sleep and reverting the drivers to 452.06 solved that. Not sure what else for you to try.
     
  20. Schwaty

    Schwaty New Member

    Same issue here... its been about a month of running on a separate monitor. I just downloaded the newest drive from nvidia. still black.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >