Razer Blade 2016 GTX 1060 (Benchmarks)

Discussion in 'Systems' started by technokat, Oct 9, 2016.

Thread Status:
Not open for further replies.
  1. Firebat246

    Firebat246 The One

    Correct if I click battery icon it pops right up.... I have clicked it enough times since I started using it that I definitely would have noticed an issue by now.
     
  2. fer.geraci

    fer.geraci Active Member

    Ok folks, i am off the Razer hook. Won't go through the whole RMA party this time. If in the future you need benchmarks of other systems with GTX 1060, just let me know, ill be happy to oblige!. it's been nice sharing with you all, until the next release i guess :stuck_out_tongue_winking_eye:
     
  3. YuenX

    YuenX Member

    Someone know when will the rzb release on Eu like Spain or Italy.
     
  4. vistar

    vistar Active Member

    Just got my hands on my new RB, my first one. My Dad got it a couple of weeks ago but I just arrived yesterday. I got a 9130 on firestrike...out of the box, I just updated windows and stuff...no graphics update or killer suite uninstall. Not bad, I am happy enough since the laptop is really awesome. I will mess around a bit and install EC4 and see what happens.
     
  5. SireOblivion

    SireOblivion Active Member

    So I've seemed to lost performance somehow and I haven't touched a thing, but both Battlefield 1 and Titanfall 2 dip well below 60fps. The only difference is I'm using the newest Nvidia drivers. Anyone experience this?
     
  6. fer.geraci

    fer.geraci Active Member

    Unconstructive FYI...

    Today I returned the RB to the best buy store... the guy from geek squad told me this is the 4th this week (only in my local best buy) that people returned. Clearly it is just 10 of us and 5 we live all close by.
     
  7. SireOblivion

    SireOblivion Active Member

    Update: So it seems that something revert my EC version back to 2.0 and I had to run the updater again. Really strange. I saw another post earlier in the thread about someone's EC update not "sticking" after restarting but mine was working just fine until maybe a couple days ago. I checked the BIOS and sure enough, it was 2.0 so I run the update again and checked the BIOS to make sure it was 4.0 and it is now and I have my performance back. Strange thing is prior to the EC update I wasn't able to get 9K or above on Firestrike, no matter what I did with overclocks and such but after the update I got 9K easily. While my gaming performance took a hit with the reverted EC version I still got 9K+ in Firestrike so I have no clue what was going on. Everything is fine now.
     
    vistar and Firebat246 like this.
  8. vistar

    vistar Active Member

    After updating the NVidia graphics to 3.7609 and installing EC4, I didn´t get the performance boost I was expecting on firestrike. score came in at 9186. Before was 9130. Bummer. prochot was activated before while now it doesn´t, though. I really like the machine though and since I don´t game much, I guess the performance good enough if no other issues show up.
     
  9. Hi guys,

    So I finally got my hands on it too after checking this thread for a little while and eventually having it distributed in my region (east Asia). Despite the mixed feedback the combination design/specs made me very keen on giving it a chance and I must say the general feeling is pretty in line with what I expected.

    Now question for WoW players, what's your feelings on it? It's the game I play the most, by far. I am well aware of the age of the game and of how it's not a good benchmark overall but still, I am a little bit puzzled to see it go relatively often in the low 30 fps and even below in certain resource-intensive areas like Valsharah or Suramar.
    My graphics settings in-game are 9 in general and 7 in raids/BG. Don't get me wrong it works all good so far, nothing game-breaking and I also have peaks around 80-90 if there is not too much to display, but I must say I expected better in terms of performance. I am around 35 to 50 fps in Dalaran, depending on the affluence.

    Have some of you been toying with the settings to find the optimal configuration? Should I just stick to it and consider it's the normal state of things for the game? Would OC be any useful? Curious to have your opinions.
     
  10. vistar

    vistar Active Member

    Not sure about the polarization thing, also the actual connector size....any recommendations on this? Asus or Alienware compatible chargers work in terms of connector size? Thanks for the info.
     
  11. chhappy7

    chhappy7 Member

    I've used Razer chargers on MSI and vice versa and it worked. Also, I needed a charger really badly and I left mine at work, and used a really old Toshiba Satellite A505 as an emergency backup and the connector size seemed good. So if the charger works with something like MSI GS40 and Satellite A505, I'd assume it's fine. Also, for MSI, I doubt they'd change connector sizes around every generation, so I would think chargers that work with more recent and a bit older models than GS40 would work fine. Not 100% confirmed on this point, but I have used GS40 and A505 chargers on Blade and worked fine.
     
    vistar likes this.
  12. Badgertista

    Badgertista Well-Known Member

    Looks like the bad batch was all sent to the same location ... lol :big_grin_:
     
  13. fer.geraci

    fer.geraci Active Member

    @vistar Hey man, I tried a bigger one and it made NO difference whatsoever. Save your bucks.
     
    vistar likes this.
  14. fer.geraci

    fer.geraci Active Member

    @chhappy7 I actually tried EC4 with an 180w charger and the laptop will not draw more energy, it is just the same.
     
    vistar likes this.
  15. Thomas_le

    Thomas_le New Member

    As I know Razer released the update to fix the FireStrike score below 9000 by this link.
    http://www.razersupport.com/gaming-systems/razer-blade/

    So, does anyone do this update and how about the performance after all?
    I have read this thread few days ago (stop at page #66) and still keep my eyes on it, but I just want to know about that update before I finish reading 40 pages left. Hope someone can confirm.

    Also, I read review on Amazon, some units look like has screen "flashing" or "flicking" issue. Is it true?

    As everyone here, I love this Blade1060, but still holding my trigger because of over 60 pages of reading, I have not seen the perfect fixing for the underclocked performance.
     
  16. Anyone's FHD 1060 battery draining while under full load but plugged in to AC? My Razer Blade 2016 slowly goes from displaying "Fully Charged" to like 98% (plugged in, not charging) in like a hour when playing Overwatch. I feel like this issue is by design but just want to confirm since googling has not been quite helpful.

    I am running EC Fix 4.0.

    Firestrike score around 9700 with 175/375 OC in afterburner.
     
  17. EliteMars

    EliteMars Member

    Hi guys, been here since page 1 and after using (and tinkering with) my blade for the past 10 days around 12 hours a day I just wanted to share my experience so far.

    On arrival I swapped the SSD, did a clean install with all the drivers from the razer support page, then all new driver updates like Intel HD and NVidia, uninstalled GeForce experience and last but not least the EC fix.

    My FS scores are 9350 stock and 9750 OC'ed, meaning its in line with other GTX1060 notebooks (since they go from 9300 to 9700 stock). But the thing that kind of surprised me the most is that It actually gamed better! It could keep GTA V at 60FPS vSync’ed, while my MSI GS43VR (that I had for a couple days before I returned it since it did not really feel like a 1.8K machine) had dips to 40ish fps after a while.

    I made a custom power plan and tweaked some settings to eventually get around 6-7 hours of watching YouTube via Chrome with keyboard off and screen to 25%. So it's definitely not the maximum achievable, since using an app for YouTube bumped up the battery life on my Surface Pro 3 dramatically, so will be trying that out in the future as well.


    Some minor problems:
    - Poor Wi-Fi reception when plugged in to a second monitor through HDMI, seems to be a known problem that has been around for at least 5 years on some MacBook’s and Dell XPS notebooks and some got it fixed by changing the router's channel or the WLAN card so I will be trying out the Intel 8260 (since it's just €14 from China).

    - Fan profile seems to be quite aggressive like some people have pointed out, even when CPU and GPU are at 28C the fans aren't spinning at their lowest setting, which seems a bit off.

    - I did have one anomaly, the screen flickering. Luckily I only had it one time and I could fix it by rebooting (and removing fancontor, but not sure if that had anything to do with it) but that definitely got me really scared :3


    Some fixes that may be useful:
    - Wi-Fi connectivity seems to be the most stable when you uninstall all killer software and drivers through device manager and then on reboot windows find them automatically and you update them through device manager.

    - The coil whine (hdd scratching kind of noises) can be narrowed down to the Sky lake CPU, lots of notebooks have that so apart from being annoying in a quiet room it's not proven to have any negative effects. But a workaround is to set the maximum processor state in advanced power plan settings lower, even 1% lower (so 99%) will drastically decrease the noise. However, keep in mind that this will lower your CPU performance, even at 99% instead of 100% the CPU will perform around 20% less.


    Also, one more thing, there’s definitely no need to worry about the cooling performance, running fire strike the GPU maxed out at 67C and while gaming (GTA V) it tops out at 78C. And generally, the CPU is around 5C cooler than the GPU.
     
    Last edited: Dec 5, 2016
  18. Nice, work. Mine performs same like yours with FS. I'm totally happy with my blade except the fan noise when idle or low CPU usage.
    Could you please share more details about the 7h power plan? What else did you do, to last the battery that long? I'm getting about 4.5h... that's what the battery pro app says.
     
    K3yj1n likes this.
  19. Your experience is very similar to mine in almost every respect. When gaming in the same room with friends on other performance laptops (every one of them is thicker than the Blade - but none are Pascal-powered), I always get a shock out of them at how much cooler the Blade's GPU is running compared to theirs. Witchcraft, they call it.

    I'm curious about upgrading the SSD. Is it particularly tricky for someone who's never done it before?
     
    vistar likes this.
  20. Badgertista

    Badgertista Well-Known Member

    It's normal to see your battery drop to 97-98% on any laptop, then get back to 100%, gaming or not.

    EDIT: 3 positive posts in a row before mine. The 10 people with issues must all be sleeping! :stuck_out_tongue_winking_eye_:
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >