Razer Blade 2016 GTX 1060 (Benchmarks)

Discussion in 'Systems' started by technokat, Oct 9, 2016.

Thread Status:
Not open for further replies.
  1. AJ_AllTheWay

    AJ_AllTheWay Member

    There should be an issue with yours because this guy played GOW4 on Ultra on his MSI 1060 laptop and received average of 74 fps
     
  2. AJ_AllTheWay

    AJ_AllTheWay Member

    Sure I will! It doesn't look that bad! Do you know what's the contrast ratio of the Blade screen?
     
  3. Ridha_Baqshi

    Ridha_Baqshi Active Member

    Try unplugging the charger during gameplay, see if that makes it any better. Because my faulty unit did that, fps drops a lot when it was charging.
     
  4. Run the in game benchmark and let me know what settings you use and what your stats are..

    I'll run the in game benchmark on mine too and let's compare..
     
  5. Thank you everyone

    Souskei, thanks for comparing, it will be very helpful to know when I call Razer how other units stack up. Unfortunately I'll be at work for the next 10-11 hrs, and won't be able to check in detail. I'm almost positive I had every setting maxed out at 1080p. The first half of the benchmark would start off at 45-50 fps. Then during the open storm/battle sequence drop to 40-45 fps.

    Ridha, I did check how things played unplugged. I got a slight bump in performance (maybe 5 fps). Arg. I hope I'm not having the same issue as you. According the Gears benchmark my frames go from being mostly CPU bound when plugged in to GPU bound when unplugged. To me this would suggest the CPU is not receiving adequate power, when plugged in. This held true even when the battery was fully charged (thinking that once the battery is done charging, more power could be diverted to CPU/GPU).



     
  6. Benj1e

    Benj1e New Member

    I just got a GTX 1060 for my Core and Stealth. I am new to the PC gaming world and bought this setup after Playing Paragon on PS4. I played Paragon over the weekend with my Razer setup and it was awesome.
     
  7. Ridha_Baqshi

    Ridha_Baqshi Active Member

    Unfortunately it seems you might have the same issue I had, because running games on battery should always give less performance than when plugged in. Try playing @1080p with lowest settings and disable Vsync then compare the performance with charger plugged/unplugged. In my test with Assassin's Creed Syndicate, I was getting about 35-45fps when plugged, but when on battery it jumpes to 60-65fps.
     
  8. AJ_AllTheWay

    AJ_AllTheWay Member

    Wow I hope mine doesn't have this problem like you guys! Do you know what causes this issue? is it a faulty hardware or software issue?
     
  9. Silvwyvn

    Silvwyvn New Member

    After unplugging my Razer Blade, I noticed a significant increase in frame rate like your's did, Ridha. Currently I am playing Assassin's Creed Syndicate with 30-50 fps at High Settings when plugged in, while reaching around 55-60 fps on battery. Also, when my Razer Blade is plugged in, no matter which graphical settings I adjust to, I am constantly running with an average of 40 fps in general.

    Does anyone else notices an improvement in performance after unplugging their Razer Blade?
     
  10. brightcinder

    brightcinder Member

    If this is being seen by more than one person, I wonder if it's actually a system defect. Going just off FPS can be misleading -- the GPU driver or game engine may be taking some other shortcut while on battery so that it's doing less work. Or some other software issue may be causing poor clocking decisions. Those would be bugs, but they won't be fixed by returning/swapping the system.
     
  11. xiaowlovely

    xiaowlovely New Member

    The laptop on default has a very conservative power limit throttle. I played dota2 at ultra setting on 3K resolution, the CPU sometimes drawdown to 0.8gpz, which is severely bad. The I use Throttlestop to unlock the power limit throttle of CPU, the performance is much more better, though the temperature of CPU could reach 80C, but still OK on this thin laptop. I think your problem is not related to the adapter.
    However, I found that the touchscreen would sometimes be not working. If I restart the computer, it does work, so I think this is a software problem, wish Razer will soon give us a new driver to fix this problem
     
  12. xiaowlovely, thanks for the post! Did you contact Tech Support to let them know? That would be great if this is just a driver/throttling issue. If enough people bring this to their attention it will hopefully get fixed sooner than later.

     
  13. xiaowlovely

    xiaowlovely New Member

    Not yet. I am quite sure that the problem is power limit throttle. Now I am trying to contact Razer to fix the touchscreen problem on my laptop. Do anyone else here have the same issue?
     
  14. I wasn't able to call, but wrote tech support a lengthy email describing the major frame-rate issues. For the premium price Razer commands for their machines, we should expect, at a minimum, the same performance to their competitors' (MSI, ASUS, etc..) similarly equipped 1060 machines. I would encourage others who are having similar issues contact Tech Support describing the problem. If they realize this issue is effecting a large number of owners they will have to address the problem, for the sake of their business.
     
    Razer|Jaisani_Choe likes this.
  15. Destrok

    Destrok Well-Known Member

    I concur, please do let the support team know, but I will also make sure they take a look at this thread. I would also like to encourage the rest of you to keep benchmarking. This certainly isn't a support thread or a place to just complain about issues, but if you have legitimate information to add to the discussion please do, the more info we have at this point, the better. Also I just kinda wanna see how well it performs since my Razer Edge is getting a little old at this point and it might be time for me to upgrade :stuck_out_tongue_winking_eye:
     
    Razer|Jaisani_Choe likes this.
  16. Ridha_Baqshi

    Ridha_Baqshi Active Member

    That's exactly what I was having. I tried every single solution possible but no luck. I tried:
    - checking all of the power settings
    - updating all drivers
    - reinstalling windows
    - checking the BIOS settings
    - a replacement charger

    None of them seem to work, the only possible thing is that it's a defective laptop. I think you should RMA yours. Sorry that you are having this issue.
     
  17. Alright....

    So im getting the same issue with the plug.

    In Doom, my frame rates are dropping between 20 - 40FPS, which is kinda ridiculous.

    Some Scenes Are around 110FPS UNPLUGGED that will drop to 75FPS when i plug in.
    Fight scenes are around 70 - 90FPS UNPLUGGED that will drop to 45 - 55FPS
    Settings at Ultra

    I seriously don't get it. This has to be some kind of bug rather than a hardware issue if this many people here are getting this.

    Anyone here anything from Razer yet? i think i may have shoot them an email as well.
     
  18. Ridha_Baqshi

    Ridha_Baqshi Active Member

    I'm really worried now that I'm gonna get a replacement with the same issue!
    Try contacting Razer and see what they say.
     
  19. Makyura

    Makyura Member

    Well, as one of those who claimed to have the same problem fixed it by forcing the multiplier on ThrottleStop its very likely it's a software or firmware bug, so you'd better just use ThrottleStop for now, while waiting for Razer to update what's cause the throttle.

    RMAing won't very likely fix anything, what they'd do is send an unit suffering the same issue or just pre-update it for you.
     
  20. Lmao Ridha I was Stephen Wang on your youtube channel. So glad I found this! I was thinking of ordering one here in Australia. How did you gets your hands on one so early? Also, if i buy from Australia will i have to get a separate adapter for the power adapter or will it come with an Australian plug in socket?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >