Razer Blade 2016 GTX 1060 (Benchmarks)

Discussion in 'Systems' started by technokat, Oct 9, 2016.

Thread Status:
Not open for further replies.
  1. Fayezjaffal

    Fayezjaffal New Member

    hey, can you please tell me if the input on the charger is 110V-240V or is it limited to 110-120V ? if you can provide a picture, that would also be great.

    thanks in advance
     
  2. Firebat246

    Firebat246 The One

    It's definitely not your fault you did more to help the cause then hurt it. This is what troubleshooting is and I'm glad we went though this early on. I'm excited to see new benchmark videos now!
     
  3. Ridha_Baqshi

    Ridha_Baqshi Active Member

    It's 100V-240V

    [​IMG]


    I'm very exited now to see how it really performs!
     
    Fayezjaffal likes this.
  4. Firebat246

    Firebat246 The One

    I'll wait patiently for updated tests!
     
  5. brightcinder

    brightcinder Member

    I'm afraid I got the system for photo editing more than gaming, I don't have any modern games to test with. But I may pick something up, and if so I'll definitely share the results.

    Results for Blade 1060 upgraded with Samsung 950 Pro SSD:
    PCMark 8 Basic (free), v3.0 OpenCL Accelerated
    Balanced power plan: 3260 (http://www.3dmark.com/pcm8/15447091)
    High performance power plan: 3409 (http://www.3dmark.com/pcm8/15449404)

    That's not bad - better than the few Blade 970M scores I found online - though well below what PCMark claims is the score system with the minimum configuration recommended for Oculus/Vive (4679). I don't know how accurate those claims are.
     
    Last edited: Oct 15, 2016
  6. EliteMars

    EliteMars Member

    Nice find Ridha
    The best way is to just change the cable to the correct cable for your country:
    [​IMG]
     
    Last edited: Oct 16, 2016
  7. PrideHeart

    PrideHeart Active Member

    It's really interesting how an adapter can mess with performance...looks like there's now a market for gaming adapters.
     
  8. Hey guys just curious if you know how accurate the battery bar pro discharge rate is? Seems like after my computer wakes from sleep its around -22,000mWh but I can restart and get around -12,000mWh both while idle. I have yet to run through a full charge to see if when its saying the higher discharge am I getting worse battery but going to try.
     
  9. DKtoss

    DKtoss New Member

    Hey All,

    Read through all of your inputs - very helpful and informative. Thank you. Great Community!

    I will be preordering my blade soon (upgrading from a stealth). I can't wait to test it out.
     
    Destrok likes this.
  10. AJ_AllTheWay

    AJ_AllTheWay Member

    May I know what would be the exact name of that power cord? Because I want to buy the European version of that too.
     
  11. Shirleja

    Shirleja Member

    You European mate? What are your impressions/experience using Hidevolution?

    I'm toying with it for a new Stealth. Did you get their global warranty and any other laptop tweaks?
     
    GHOST2706 likes this.
  12. AJ_AllTheWay

    AJ_AllTheWay Member

    Not really. I'm originally from Saudi Arabia, but I live in US. In Saudi Arabia, we use the European plug mostly. So I have to buy the said cord for when I visit the country.
     
  13. EliteMars

    EliteMars Member

    It's the ''Mickey Mouse'' C5 power cord:
    [​IMG]

    Just looked at it and wouldn't advise it because you HAVE to take global warranty to have any warranty, while if directly ordered from razer you can send it for warranty to an EU razer adres. And also shipping (atleast for the Netherlands) is 2 times as expensive as some US to EU shipping companies like myus.com.
     
    Last edited: Oct 16, 2016
    AjwadSabano likes this.
  14. Ridha_Baqshi

    Ridha_Baqshi Active Member

    Hey guys, I'm back again as I was busy with uni assignments. So I bought the AU adaptor, the same one as this:
    [​IMG]

    Unfortunately it didn't improve anything. I already contacted Razer regarding a replacement charger and this is what they said:

    Hi Ridha,


    Thank you for providing the required information . I forwarded this to the Razer RMA team who will be processing your RMA request. The team will get back to you shortly with more information regarding your RMA request. While most RMA escalations are answered within one to two business days or less, some escalations can take a bit longer depending on support demand.


    Should you need any further assistance please let us know and I will be happy to help.



    Sincerely,

    Kyo

    Razer - Tier 1


    I'm hoping that I don't have to send in my charger as I really need to use the laptop for uni.
     
  15. AJ_AllTheWay

    AJ_AllTheWay Member

    Razer Blades have massive QC issues. I notice that you go from one problem in 970m Blade to another in 1060. Why would I spend an arm and a leg on this if that's what I have to face? Razer should inspect all of their Blade products before they go out of the factory on a product-by-product mechanism. That's the only thing that perhaps might work with them.
     
  16. Firebat246

    Firebat246 The One

    Wow so the issue is definitely with the charger itself? Did they do any troubleshooting steps with you or just assume that's causing the issues?
     
  17. Ridha_Baqshi

    Ridha_Baqshi Active Member

    What else could it be? I'm just assuming it's the charger since the problem only occurs when it's plugged in. Hopefully nothing internal :slightly_sad:
     
  18. Firebat246

    Firebat246 The One

    I don't mean to alarm you I just figured they might run a few tests remotely to see power intake while plugged in. Just normal troubleshooting before just replacing it on a whim. Granted it almost certainly seems like it's the power supply but you never know.
     
  19. Do you have a miltumeter by any chance?
     
  20. Ridha_Baqshi

    Ridha_Baqshi Active Member

    Yeah I can get one from uni.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >