Razer blade 2018 - Battery issues

Discussion in 'Razer Support' started by Ahuri3, Nov 23, 2020.

Tags:
Thread Status:
Not open for further replies.
  1. Ahuri3

    Ahuri3 New Member

    Hello !

    Both in my linux and windows operating system the battery information shown is wrong :
    • In linux the battery is always seen at 0 percent.
    • In windows the battery is always seen at 100 percent.
    • Sometimes linux and windows will agree in a percentage but it won't ever go up or down.
    • The battery percentage sometimes changes if I plug/unplug the laptop multiple times, but afterwards it will stay stuck at the "new" value.

    My Product number is : RZ09-02386G91 and I would gladly like to know how to fix this issue.
     
  2. static-626

    static-626 New Member

    Hey mate,

    I have a suggestion for you to try, consider opening your PC and verifying the battery cable is connected properly, I had an issue where my PC showed "Battery Not Present" and when i opened it I noticed my battery cable was partially connected. I've disconnected and reconnected and after powering on my PC showed correct values. Aslo make sure the pins on the connector are clean.

    If my suggestion didn't help it could be another underling issue.
     
  3. Ahuri3

    Ahuri3 New Member

    So today my battery started to inflate a lot.
    I poped open the laptop and the case almost removed itself because of the pressure from the battery !

    The battery is going to the appropriate battery bin nearest to me tomorrow morning and I'm buying a new one.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >