Razer Blade advanced 2019 unable to recognize charger.

Discussion in 'Razer Support' started by the_flesh_that_hates, Oct 8, 2021.

Thread Status:
Not open for further replies.
  1. Hi guys, I have a 2019 RBA. I've only had it a year. I've been using it without the battery/as a desktop.

    A few weeks ago, it just randomly stopped recognizing the charger at all. I was literally using it a few minutes before this, I had powered it off and unplugged it like always but when I came back, it acted bricked.

    To make sure the laptop still worked I put the battery back in, and it powers on. But it does not even register when it's plugged in. No "Plugged in- Not charging". Nothing. It just says "on battery". The light on the adapter still turns on.

    I contacted Razer Support- and they did get me a new adapter, but a 200W, not the 230W that came with my laptop, but I decided to try it anyway. Same issue, any outlet, any charger, any power cord, battery or none; the adapter light comes on but the laptop cannot draw power.

    I'm starting to think this is somehow a physical issue with the circuitry in my Blade. Please help?
     
    Last edited: Oct 8, 2021
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Sorry to hear about your laptop's charging concern. Please perform the steps from this link and see if it helps. Otherwise, send me a PM including your laptop's serial number so I can check its details and available updates. I'll be locking this thread to curb our conversation privately.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >