Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Blade Base 2018 - Stuck on booting Razer logo screen

Discussion in 'Razer Support' started by 3empanadas, Jul 31, 2020.

  1. 3empanadas

    3empanadas New Member

    Hello guys, thank all in advanced.

    I've researched this forum a lot and other pages as well, trying to get some kind of solution for this and i haven't found anything that worked so far.

    The problems is with no visible changes made from the SO or programs installed, the notebook stopped booting and stucks in the Razer logo screen, with 3 options, f12 boot menu, f1/del bios and f9 recovery.

    None of this keys responds or does anything. No matter how many times i try to shut it off and on or combination of keys.
    I tried, unplugging and shuting down with the button pushed for 30 seconds, all sort of combinations of this kind of sequences and nothing. No change.

    Needless to say that is out of warranty and also here in Argentina there is no Official service from Razer so no much luck with that either.
    I've sent them a case support, despite not having actual warranty in case the could give me some advice but i understand if they do not give any.

    So here i am, sorry for the "long" post, i tried to be as explicit as i can.

    P.D: i'm also attaching a photo of the said screen, but i can imagine you all know what i'm talking about.

    56d3d609-80f7-4b19-a709-eddf0bfa2585.jpg
     
    kazresearch and bicepsking like this.
  2. bicepsking

    bicepsking New Member

    same here - did you ever find a solution?
     
  3. 3empanadas

    3empanadas New Member

    Hello, well i am not 100% sure yet... but it seemed to be the nvme that was malfunctioning.

    With the nvme drive connected the laptop entered in the state i described in the original post and there was no way or option to go foward.

    When i removed the nvme drive, it booted and prompted for a Os disk. The bios worked normally and everything was working as expected with no OS drive.

    After that i installed Windows 10 in the HDD, and worked like a charm. Of course, the booting up time, apps and games all got impacted in performance as it is now using an hdd and no ssd, but at least it is not a 1500dls brick haha.

    Finally, this laptop is not mine and my friend did not get a new nvme drive to confirm 100% if is the motherboard with a failure or the nvme drive itself, yet.

    He's planning to get a new one but, as everything is extremely expensive here in Argentina, we're still waiting for it.

    One final coment, despite not having a valid warranty or razer care or anything, i wrote the Razer support and got awesome responses i even requested them the original image to restore when we get the new nvme drive and they sent me a link and everything. Really really, helpful.

    Sorry for the wall text, so far that is my experience. Feel free to dm me if you have any questions :)
     
    kazresearch likes this.
  4. bicepsking

    bicepsking New Member

    Awesome, thanks. Not going to be thrilled if the nvme drive is bad, since i have a lot of work on there that hadnt gotten backed up from that day. Will feel similarly if i have a $2000 brick, ha

    I'll try pulling the nvme.
     
  5. bicepsking

    bicepsking New Member

    In case your wondering, if you/your buddy still has the NVME, I just popped mine into an enclosure and check on my desktop - all my data is intact. Otherwise, same boat as you right now. Getting ready to install a new drivein the Blade. If that doesnt work, then yeah, assume it's the board.
     
  6. KRebacz

    KRebacz New Member

    Hi, I’m having the same issue with my Blade 15 studio.
    Did the new drive help?
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >