Razer Blade Pro 2014 Doesn't Charge - Help?

Discussion in 'General Discussion' started by Vueeyle244, Mar 19, 2016.

Thread Status:
Not open for further replies.
  1. Vueeyle244

    Vueeyle244 New Member

    Hi everyone,

    Has anyone encountered a problem after updating to Windows 10 and their battery doesn't charge?
    Mine sometimes turns on and says `100% charged' and some other times says `0% Calculating" and it stays like.

    I downloaded a battery status application called "BatteryInfoView" and it sometimes detects the details of my battery and sometimes don't... It sometimes also comes up with the Battery Wear is currently only at 89%, so it is still a healthy battery, just not sure what is going on...

    This has happened soon after I updated to Windows 10, I left it over night to transfer files from my old HDD and I found out the following morning that I forgot to plug in the charger, then I soon discovered that my laptop won't charge anymore. I have also done the uninstall `Battery ACPI" method and etc, but sadly it doesn't help.

    I really want to avoid sending in my to get it repaired because of my Uni assessments are due soon, and I really need a laptop to be portable.

    Any ideas on how to fix this? Unless sending it in to Razer to replace the battery is the only choice I have now? Capture.JPG
     
  2. kajira

    kajira Mother of Gaming

    It's possible that someone here might have a response for you regarding having had this issue, however, your best bet for real support is to actually contact Razer directly at Razer Customer Support and get an official response for your issue. They will have the most up-to-date information and be able to provide the most detailed support.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >