Razer Blade Pro Gaming Laptop Not Charging, Making Buzzing Noise When Plugged in.

Discussion in 'Razer Support' started by nuggetism, Dec 11, 2020.

Thread Status:
Not open for further replies.
  1. nuggetism

    nuggetism New Member

    My Razer Blade Pro Gaming Laptop from 2016 at about 2 am last night had stopped charging, after flickering from charging to not charging for about an hour and a half. When it shut off from being unplugged for a bit, I took off my headphones and heard a buzzing noise. it's much louder than normal, and it's coming from the left of the laptop, where it's charging. I'm not sure if it's a charger issue or an issue with the laptop. I had just recently bought a new charger a month or two ago. Yes, the power brick was hot when I inspected it. This morning is more of the same. Any help would be appreciated.
     
  2. Kris3909

    Kris3909 New Member

    I am having the same problem since installing the latest windows 10 update. My power cord powers the laptop and my battery is at about 80% but will not charge at all. The battery icon just says the percentage of charge no "plugged in and charging/not charging." Power brick is also warm. Used the power cord from another Razer (this cord works fine on the other computer) and no difference, leading me to believe it is a windows issue. I uninstalled the battery driver and reinstalled and it will charge for between 30-60 seconds before it stops. Same thing is true with unplugging and re-plugging the power cord. This probably isn't too helpful, but if you recently updated windows maybe you are able to revert.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >