Razer Blade Stealth 13 2019 crazy loud coil whine

Discussion in 'Razer Support' started by gambiting, Apr 16, 2019.

Thread Status:
Not open for further replies.
  1. gambiting

    gambiting New Member

    Hi,

    So on my Blade Stealth 13(graphics model) I'm having an issue with crazy coil whine any time the disk is accessed. It's not coming through the speakers - even when muted the noise can still be heard. It doesn't matter if the laptop is in low power or creator mode - there is a very loud coil whine(scrubbing-like electrical noise) coming from the laptop.

    I've heard that Razer is offering a special BIOS for those laptops affected by this - any chance I could get such a special BIOS for mine please? My serial number is:

    Product no: RZ09-02812W71
    Serial no: REMOVED

    thank you!
     
    Last edited by a moderator: Apr 17, 2019
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Can you share a short video of the issue so we can take a closer look?
     
  3. gambiting

    gambiting New Member

    Hi RedPanda! Of course - here's a video I just took:



    To add to this - the sound persists no matter if the laptop is plugged in or not, but it's louder when plugged in. Selecting Creator Mode/Balanced/Low Power in Synapse has no impact on the sound - it's always there.

    However, I have found a suggestion that "fixes" it - using ThrottleStop and disabling TurboBoost on the CPU gets rid of that sound entirely! However, that is not a "fix" in that without TurboBoost the CPU is limited to 2.0GHz and therefore much slower than acceptable. So if you do have a BIOS update that could fix it, it would be really appreciated!
     
    Last edited: Apr 17, 2019
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the video. You should be able to find the link to the BIOS updater here. Let me know how it goes or if you have any questions.
     
  5. gambiting

    gambiting New Member

    Edit: Ok, after following the link it turns out I didn't have BIOS 1.02. When I ran the updater it said that it will upgrade my BIOS from 1.01 to 1.02.

    So I ran the updater.....and the progress bar got to the end, and now appears stuck? It's been at 100% for 15 minutes now with nothing happening. What do I do now?

    Edit2: This is not my videos, but it does the exact same thing as for this guy:
     
    Last edited: Apr 18, 2019
  6. gambiting

    gambiting New Member

    After leaving the laptop for ~10 hours, it still hasn't finished updating the BIOS. The mouse and keyboard are still locked. Please advise what to do next urgently.
     
  7. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for the update. Please PM me the serial number of your Blade. I'll pick it up from there.
     
  8. gambiting

    gambiting New Member

    Hi, just sent you a PM with the serial number
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >