Razer Blade Stealth 13 2019 problem with install ubuntu in DUAL-BOOT

Discussion in 'The Linux Corner' started by RubrexTheOne, Jul 13, 2019.

Thread Status:
Not open for further replies.
  1. RubrexTheOne

    RubrexTheOne New Member

    Hi folks!

    I tried to install ubuntu 19.04 on my Razer Blade Stealth 13 2019, but encountered on the problem.
    I replaced ssd disk to Adata XPG sx8200 pro 1TB, then installed Windows 10 Pro, then shrink the size of volume and created new partition with around 250GB of space.

    I disable hibernation mode on Windows by executing command in Command Prompt (under Admin):
    powercfg.exe /h off

    I created booted USB with ubuntu, I used Rufus 3.5. I tried both partition scheme MBR and GPT.

    I disabled secure and fast boot in bios and SATA Mode selection was and is AHCI from the begging.

    But when I boot from USB and tried to install ubuntu 19.04 (I even tried 18.04) I receive an error

    you need at least 8.6 gb disk space to install ubuntu


    Under "Try ubuntu" mode I started Gparted and Disks utilities and both of them doesn't see my SSD.

    I don't know what to do, I made some research in google and for almost all people problem was that SATA Mode was not AHCI, but my mode is. Maybe somebody could help me with my problem?
     
  2. RubrexTheOne

    RubrexTheOne New Member

    Ok, I did it, I write it under ubuntu 19.04 on my notebook.

    This actually problem with nvme drivers. If you have such problem, then you have to add additional boot option in grub menu for "install ubuntu": nvme_core.default_ps_max_latency_us=200

    https://askubuntu.com/questions/109...l-to-boot-nvme0-failed-to-set-apst-feature-19

    also I found github repo with very helpful information for Razer Blade Stealth
    https://github.com/rolandguelle/razer-blade-stealth-linux
    I guess I could use patch for grub from that repo. It's sad that I found it only now, after all my problems.
    Also there are a lot of cool advises.

    But after this I encountered on another problem. Ubuntu installs well, but at the end of installation shows new error
    the 'grub-efi-amd64-signed' package failed to install into /target/

    After some research this one fixed my issue
    https://help.ubuntu.com/community/Boot-Repair

    But after installation I encountered one more problem, Boot drops to a (initramfs) prompts/busybox
    And this is actually the first problem, all that I have to do it is add boot option but now for fresh installed ubuntu under ubuntu life usb.

    This is not first time I install ubuntu, I use it from 14.04 version on the desktop, and actually this is first time I have such a lot of problems. Partially because of NVME storage, probably partially because of DUAL BOOT in UEFI mode, earlier I did ubuntu installation in legacy mode.

    I hope my researches could help someone :)
    Best wishes.
     
  3. RubrexTheOne

    RubrexTheOne New Member

    BTW I also have some problem with fans control, on windows in idle time they are not working at all, but on the ubuntu they are always run, even on idle, it's annoying me. My quick attempts to fix it did not bring the desired result. So I will write if I fix it.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >