Razer Blade Stealth ( 2015 ) 12.5 touch screen missing ?

Discussion in 'Systems' started by danielyohanson, Aug 21, 2022.

  1. danielyohanson

    danielyohanson New Member

    My Razer Blade Stealth - Touch Screen Not working
    on device manager Appear on Usb tab - Unknown Usb Device ( Device Descriptor Request Failed )

    - Newest Bios
    - Intel Support up to date
    - Windows 10 latest update

    Any suggestion for my problem?

    Thank You
     
    pancholr and JulianKapa like this.
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Is this the original operating system that the unit came with it? If not, I suggest reverting the laptop's operating system to its factory state as there's a possibility that the driver allocation for your touch screen was corrupted during the software upgrade. If you don't have a copy, you can try clicking this link and selecting the Get System Recovery Image under the online service & resources section.

    *Moving this thread to our systems boards.
     
    pancholr and JulianKapa like this.
  3. danielyohanson

    danielyohanson New Member

    Already Restore from Recovery Image but still not working.

    any other suggestion ?

    thank you
     
    JulianKapa likes this.
  4. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Are you using the laptop's original SSD? Also, please check out the suggested steps from this article: https://mysupport.razer.com/app/answers/detail/a_id/1784/.
     
    JulianKapa likes this.
  5. danielyohanson

    danielyohanson New Member

    im using original SSD.

    i already follow steps from that article , i can not find on device manager like that

    i upload my screenshot of my device manage on windows 10

    Thank you for your help
     

    Attached Files:

  6. FiszPL

    FiszPL Well-Known Member VANGUARD

    Can you check the properties of the Unknown USB device? Then go to details tab, select Hardware Ids from list, and paste VID_PID of the device.
    Also you can try to remove this faulty device (right click -> Uninstall, if there will be checkbox to uninstall driver, check it also). Restart PC then check device manager what appeared.
     
  7. danielyohanson

    danielyohanson New Member

    yes i can check the properties of the unknown usb device
    but still no idea what to do ..
    on detail - hardware id just "USB\DEVICE_DESCRIPTOR_FAILURE'

    about uninstall driver - then scan new hardware again
    - unknown usb device appear again like before

    Device USB\VID_0000&PID_0002\5&7a3b51&1&9 was not migrated due to partial or ambiguous match.

    Last Device Instance Id: USB\VID_090C&PID_1000\04HR000000000619
    Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
    Location Path:
    Migration Rank: 0xF000FFFFFFFFF132
    Present: false
    Status: 0xC0000719


    btw thank you for the reply : )
     

    Attached Files:

    Last edited: Aug 25, 2022
  8. BrusterThemand

    BrusterThemand New Member

    I have the early 2019 model but both are basically experiments in a razer chassis. Half the stuff breaks (Mine has wack hinges, and came back with a stuffed trackpad after getting repaired for being defective). I recommend getting a replacement screen as that should fix it.
     
  9. danielyohanson

    danielyohanson New Member

  10. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    I appreciate the recommendation!

    Hey danielyohanso! If you need further assistance, please send me a PM, including your laptop's serial number so I can check if it's eligible for an out-of-warranty repair. Thanks for your cooperation.
     
    danielyohanson likes this.
  11. danielyohanson

    danielyohanson New Member

    thank you for your help @Razer.Speedcr0ss
     
  12. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    You're welcome! Just send me a ping so I can check your laptop's info and eligibility to undergo the repair. Cheers.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >