Razer Blade Stealth Kaby Lake Linux

Discussion in 'The Linux Corner' started by seanwrhodes, Feb 5, 2017.

Thread Status:
Not open for further replies.
  1. Hi All

    I got a Razer Blade Stealth recently and installed Kali Linux on it. Have a few issues but most of the threads were quite old and talked about 4.4 kernels. I started on 4.9 so most wasn't applicable so I thought I would start my own in case anyone has found ways to fix these

    The issues I have:

    - Display Flickering running at native resolution, the display flickers aggressively to the point that its unusable. Either dropping down the resolution to 1920x1080 or having an external monitor connected and its absolutely fine. I tried the "Intel-Microcode" and open source drivers but they don't change it at all.

    - Caps Lock Key crashes If the caps lock key is pressed twice, the machine will crash. Once is fine but having to reboot to turn it off is annoying!

    - Cant resume after lid close Think this is quite common but none of the scripts people have written worked for me

    - Firmware warning message when booting As Killer don't offer the .bin files anymore, I can't use the fix everyone did so I get a message saying "Problem accessing /ath10k/***" when booting. No real issue but slows down booting.

    Don't suppose anyone knows how to fix these?!

    Thanks in adv.
     
  2. Snubber

    Snubber New Member

    Hey I'm pretty much in the same boat as you except I was able to fix the flickering issue by upgrading my kernel to 4.10

    Best of luck and let me know if you are able to fix any of the other stuff!
     
  3. Hi,
    My RBS KabyLake have also some problems similar to yours. It's on Ubuntu 16.04.2 LTS.
    On kernel 4.4.0-64 complete and silent freeze once or two by day, and CapsLock sometimes turn to immediate freeze with anomalies on screen. I remark the CapsLock problem is randomly active at start or not and after changing of keyboard layout or external plug/unplug. The NumLock have also the problem on external keyboards.

    On kernel above, it's a nigthmare, i.e with kernel 4.8.0-39, no resume, CapsLock ALWAYS freeze the beast.

    Do you use the unofficial chroma razer driver from terrycain on github ?
    I'm trying to remove them to test the stability of the system.
    I'll repost for the results here.

    Terrycain razer drivers are not guilty. It seems the computer is more unstable when it is attached on an external (HDMI) screen.
     
    Last edited by a moderator: Mar 27, 2017
  4. laserone_

    laserone_ New Member

    I have the same problems. I am compiling the 4.11 kernel now to see if it makes any difference.

    I also have issues with the wireless NIC connecting--it takes forever to connect and is very slow with a lot of dropped frames...

    The 4.11 kernel didn't fix anything however I've managed to figure out the last few issues and everything except the webcam and CAPS (mostly) is working perfectly.

    My RBS had constant flickering when booting and certain display modes wouldn't take.

    To fix, modify /etc/default/grub

    #Fix screen flickering and the suspend/resume loop issue:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet button.lid_init_state=open i915.enable_rc6=0 splash"

    #Install Plymouth for a nice splash screen if you want. Do not modify/add modules to the initramfs configuration. You will need to use videoinfo to determine modes the display supports to ensure Grub can display correctly. I modified the following items in /etc/default/grub:

    GRUB_GFXMODE=2560x1440x32
    GRUB_GFXPAYLOAD=keep

    Update initramfs: update-initramfs -u

    GDM3's resolution is incorrect and doesn't transition nicely. First, set your desired resolution within Gnome settings for the display.
    Then: cp ~/.config/monitors.xml /var/lib/gdm3/.config/
    Restart GDM3 or reboot.

    My distributions ath10k firmware binaries were old, ensure you have the following binaries in: /lib/firmware/ath10k/QCA6174/hw3.0

    82223d65048e43a6f8b16d09a55c30a8 board-2.bin
    cb37c63d9ca28f53fea1ff09ad7c7a82 board.bin
    a5dfbc03c9a7a73f7aa8d0a94a6d9426 firmware-4.bin

    They can be obtained and renamed to the above from: https://github.com/kvalo/ath10k-firmware/tree/master/QCA6174/hw3.0
    Normally you shouldn't mess with anything in /lib. If you don't have wifi problems don't do this or wait for your distribution to update them.

    Also, there are certain AP channels you should avoid. Check with: iw list
    Some will show disabled. It may be a good idea to assign one on your access point that is not disabled for this card...

    Power management on wifi seemed to degrade performance, turn it off: iwconfig wlp1s0 power off
    Wifi now stays connect and only take 1-2 seconds to authenticate on a cold boot.

    To get rid of intel graphics messages about missing firmware go to: https://01.org/linuxgraphics/downloads/firmware
    Download the KabyLake GuC, DMC (should be already present on system) and HuC binaries. Use the install script with each to install them. This is only to rid an annoying log message, it shouldn't be needed.
    Reboot.

    To fix the Caps-lock freeze issue ensure you are running the latest razer-drivers from: https://github.com/terrycain/razer-drivers

    The razerkbd kernel module must be loaded. I have seen inconsistent behavior with this. It still appears to freeze the system on the GDM login screen. If in a terminal or other application it doesn't...

    I am using Debian so I compiled them from source. I used the python3-evdev package from Ubuntu repositires and installed it with dpkg because installing it through pip failed... and I'm lazy.

    Compile: https://github.com/lah7/polychromatic

    Google hangouts and the RBS' camera are laggy and are unusable in Google Hangouts. Making the following change in /etc/modprobe.d/uvcvideo.conf has no effect:

    ## fix issue with built-in webcam
    options uvcvideo quirks=512
     
    Last edited by a moderator: Mar 27, 2017
    Snubber likes this.
  5. headfeverDenim134

    headfeverDenim134 New Member

  6. Snubber

    Snubber New Member

    Thanks for all of the helpful info!

    I tried using this fix to fix the issue with suspend/resume:
    And it didn't work for me. I made sure to update-grub as well.

    When my RBS goes into suspend and then I open the lid it doesn't do anything. If I press a key the keyboard blacklights come on but the screen is still black. Any ideas on what I can do?

    Thank you.
     
  7. My RBS is quite stable only on Lubuntu/Ubuntu kernels 4.4.0-xx canonical series.
    I deactivated suspend on clamshell since the wake has the problem you describe. I suspend the OS manually from the menus. I do not try anymore the suspend when it is connected on an external HDMI screen.

    Despites this precautions, silent (logs) crashes occurs, more often when HDMI is in use (and my external razer keyboard, but I do not know if it is a cause).
     
  8. Positonic

    Positonic New Member

    Resolutions for most of the issues mentioned above are listed here.

    I have installed Ubuntu 17.04 Gnome and it's working quite will along with the fixes in the link above, but my touch screen isn't working at all, anyone have any ideas about how to fix that?
     
  9. I confirm the disabling of the keyboard "AT Raw Set 2 keyboard" in the above link finally stabilized my RBS. Before this change it was very unstable when I plugged external displays or keyboards, when waking, when halting, simply idling. This nightmare is closed. @Positonic. thanks for your link
     
  10. tamashumi

    tamashumi New Member

    I've been considering to get a new RBS but till anything official happens about Razer support for linux I better wait.

    I've got a Razer Blade (2014) and (now) it runs almost* entirely fine on Ubuntu 16.04 LTS (kernel 4.6). I don't won't to go through fixing/patching/waiting for kernel fixes again, especially I carry it to the office and use to make for living.

    * - screen blinks from time to time and hibernation is flaky (sleep if fine though).
     
  11. kir13y

    kir13y New Member

  12. kir13y

    kir13y New Member

  13. headfeverDenim134

    headfeverDenim134 New Member

    Touchscreen is working fine with 17.04 & Gnome (or Unity) and X11 (or Wayland).

    * $ libinput-list-devices
    your touchscreen should be listed with something like:
    * Device: ELAN Touchscreen
    * Kernel: /dev/input/event15

    Now check if the device receive events:
    * $ libinput-debug-events --device /dev/input/event15
    (replace event15 if your values are different)
     
  14. cyberialearning

    cyberialearning New Member

    I have all the listed problems.

    Those who have upgraded to 17.04 - can you confirm it fixes most if not all of these problems?
     
  15. razor950

    razor950 New Member

    regardless of what linux distro you are on, being on the latest kernel brings the most fixes to many of the issues stated here and on other threads. 17.04 brings 4.10 kernel version, so I'd update and consider manually updating to 4.11 at the very least but higher is fine.
     
  16. cyberialearning

    cyberialearning New Member

    I'm already at the latest (4.13?) kernel with 16.04.

    I still have that flickering upon boot up, the freezing when hitting caps lock, and so on.

    The only thing the latest kernel fixed is the flickering during normal use. I would hope if I just install 17.04 then I could finally be comfortable with Ubuntu on this machine.
     
  17. kir13y

    kir13y New Member

    What Blade do you have? I have the stealth and have gotten everything to work perfectly with debian + KDE.
     
  18. cyberialearning

    cyberialearning New Member

    I'm using the Stealth also, the 12.5" with i7 7500u.
     
  19. For any that may stumble upon this. The caps lock we were able to resolve be disabling with the below commands and suspend loop by modifying a grub configuration. I still need to test the razer kernel module for a better approach to the caps lock fix (Secure boot needs to be disabled or the module needs to be signed to be able to test the module)

    Fedora 25/26 and Kali
    Caps Lock:
    setxkbmap -layout us -option caps:ctrl_modifier
    gsettings set org.gnome.desktop.input-sources xkb-options "['caps:ctrl_modifier']"

    Suspend Loop:
    Modify /etc/default/grub and append "button.lid_init_state=open" to whatever the variable GRUB_CMDLINE_LINUX_DEFAULT is set to.

    Make the grub config. Example for grub2/EFI and regular grub:
    "grub2-mkconfig -o /etc/grub2-efi.cfg"
    or
    "grub-mkconfig -o /boot/grub/grub.cfg"
     
  20. tamashumi

    tamashumi New Member

    I've just received 13.3" RBS and installed Ubuntu 16.04.03 LTS on it (kernel 4.10).
    Everything was fine at first, I thought until I've connected external screen over HDMI - this causes screen (the external one) flickering and blinking a lot. Caps lock crash has manifested itself as well.

    dmesg command shows:
    Code:
    [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
    ...which I believe to be the same issue as OP's. It's not related to any specific linux distro but linux kernel (i915 driver, to be more specific).

    I've managed to find a workaround. Setting a following kernel boot param stops the screen flickering issue:
    Code:
    i915.enable_rc6=0
    However, as far as I understand, it disable CPU and GPU energy saving, which doesn't make it a proper solution.

    Please find here a relevant bug raised at Ubuntu's launchpad.

    Not sure how screen flickering and caps lock crashes are related to each other but after setting this flag hitting caps lock doesn't crash anymore either.
     
    Last edited: Sep 25, 2017
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >