Razer Blade Webcam on Ubuntu 16.04

Discussion in 'The Linux Corner' started by sam_hains, Jun 18, 2017.

Thread Status:
Not open for further replies.
  1. Has anyone been able to get the webcam working properly for the Razer Blade on Ubuntu 16.04? I am using the Kaby Lake version, and it runs, but it is glitchy as f&*k and practically unusable for three.js development/open CV development/ google hangouts. It works perfect on Windows, so it must be a linux driver problem.

    I get strange horizontal lines appearing in the image, a terrible frame rate (1fps?), and image glitches.

    When I run cheese on the command line I get this error after seeing a few frames and then it crashes:


    libv4l2: error got 4 consecutive frame decode errors, last error: v4l-convert: libjpeg error: End Of Image

    (cheese:4221): cheese-WARNING **: Failed to allocate a buffer: gstv4l2src.c(884): gst_v4l2src_create (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin18/GstV4l2Src:v4l2src1​

    has anyone had any luck? I would love to have this fixed.

    Thanks,

    Sam
     
    Last edited: Jun 18, 2017
    stuartcampbell likes this.
  2. works fine if you set the resolution to 176x144 or below.
    anything higher doesn't work.
    obviously not great but might get you through some basic scenarios.
     
  3. Hey @linuxrazer3 ! Your right that works! is there a way to configure it so that it only uses 176x144 in webcam mode (for use with google hangouts, three.js etc.)
     
  4. @sam_hains
    not sure how to do that, if you figure it out I'd be keen to know
     
  5. Is that a different webcam than what is on the RB Pro? I know that the RB Pro webcam worked out of the box after installing the Linux 4.11 Kernel. Have you done the kernel upgrade yet?
     
  6. I'm running 4.11 on Ubuntu 17.04 on the RB Kaby Lake (not Pro/Shield)

    lshw gives me this:

    /0/100/14/0/7 multimedia USB Camera


    *-usb:2
    description: Video
    product: USB Camera
    vendor: 11121119-000JM348J
    physical id: 7
    bus info: usb@1:7
    version: 0.02
    serial: 200901010001
    capabilities: usb-2.01
    configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
     
  7. linuxrazer3, I'm pretty sure that's the same webcam we have in the pro:

    *-usb:3
    description: Video
    product: USB Camera
    vendor: 11121119-000JP10GF
    physical id: 9
    bus info: usb@1:9
    version: 0.02
    serial: 200901010001
    capabilities: usb-2.01
    configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s

    Maybe has something built-in that is helping us? We're using Elementary OS Loki with 4.11 kernel.
     
  8. LumberOPALpulse079

    LumberOPALpulse079 New Member

  9. @Tolarian Yes it seems this is a known issue, however today I tried out 'Zoom' conference software on Ubuntu and the webcam works perfectly! I have no idea why it works, but it must be of interest to whoever is trying to fix this bug, as this would suggest the problem is software related rather than hardware/driver??. The Webcam still doesnt work in Google Hangouts or Cheese.
     
    Last edited: Jul 27, 2017
  10. razor950

    razor950 New Member

    I would be willing to look into this issue but I do not have a razer blade at the moment. I had a friend who would lend me his but he had to sell his.

    Besides the webcam, is there other drivers that need some looking into? I seem to see some sleep bugs with intel driver but I believe I keep reading that newer kernel versions fix that.
     
  11. I am on the latest released kernel 4.12. sleep seems to work for me on the integrated graphics card, but with discrete graphics card it seems that it is not fully 'sleeping' and i will hear the fans buzzing and starting up sporadically and the battery still gets drained. When open the screen back up, it seems that some kind of graphical glitch occurs on the desktop. Otherwise, everything is working well for me.
     
  12. razor950

    razor950 New Member

    what drivers are you using for the discrete card?
     
  13. 381.22 installed from 'ppa:graphics-drivers' ubuntu repository
     
  14. razor950

    razor950 New Member

    well, if you are fine with upgrading to a newer version just for testing, I'd upgrade to 384.59 and see if it happens to fix issues. I see some things on the readme but they don't specifically apply to sleep or wake up issues but who knows.

    worse case, you'll need to revert but it isn't that big of an issue to be honest.
     
  15. yeah sure, i'll upgrade now and let u know how it goes!

    ok so i just tested this, and it looks like suspend is working after the update. However the graphic glitch on the home screen still occurs.
     
    Last edited by a moderator: Aug 2, 2017
    razor950 likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >